Spontaneous monitor resolution/rotation changes

I’m running Xorg headless in a cloud environment on a Tesla M60. I need a large desktop, so I’ve configured 2 x 4K virtual monitors combined with TwinView to one logical screen. This works fine for my use case, but I’ve run into an issue where after running for a while or when running certain programs like ‘gnome-session’, the resolution and rotation of the virtual monitors spontaneously changes. I can fix it with xrandr, but I need to prevent these spontaneous changes. Is there a way to force the layout to stick?

I’m running:
RHEL 7.4
Nvidia GRID driver 384.73
Xorg 1.19.3

My Xorg configuration file:

Section "ServerLayout"
    Identifier     "TwinLayout"
    Screen         0 "metaScreen" 0 0

Section "Monitor"
    Identifier     "Monitor0"
    Option         "Enable" "true"
    Option         "DPMS" "false"

Section "Monitor"
    Identifier     "Monitor1"
    Option         "Enable" "true"
    Option         "DPMS" "false"

Section "Device"
    Identifier     "Card0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "Tesla M60"
    BusID          "PCI:0:29:0"

    Option         "MetaModes"          "3840x2160 { Rotation=right }, 3840x2160 { Rotation=right }"
    Option         "ConnectedMonitor"   "DFP-0, DFP-1"
    Option         "MetaModeOrientation" "DFP-1 RightOf DFP-0"

Section "Screen"
    Identifier     "metaScreen"
    Device         "Card0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "True"
    SubSection "Display"
        Modes "3840x2160"