Sporadic initialization failure from INvSIPLCamera

Please provide the following info (tick the boxes after creating this topic):
Software Version
DRIVE OS 6.0.8.1
DRIVE OS 6.0.6
DRIVE OS 6.0.5
DRIVE OS 6.0.4 (rev. 1)
DRIVE OS 6.0.4 SDK
other

Target Operating System
Linux
QNX
other

Hardware Platform
DRIVE AGX Orin Developer Kit (940-63710-0010-300)
DRIVE AGX Orin Developer Kit (940-63710-0010-200)
DRIVE AGX Orin Developer Kit (940-63710-0010-100)
DRIVE AGX Orin Developer Kit (940-63710-0010-D00)
DRIVE AGX Orin Developer Kit (940-63710-0010-C00)
DRIVE AGX Orin Developer Kit (not sure its number)
other

SDK Manager Version
1.9.3.10904
other

Host Machine Version
native Ubuntu Linux 20.04 Host installed with SDK Manager
native Ubuntu Linux 20.04 Host installed with DRIVE OS Docker Containers
native Ubuntu Linux 18.04 Host installed with DRIVE OS Docker Containers
other

Hi, when we attempt to initialize a camera interface via INvSIPLCamera::Init() it sporadically fails with NVSIPL_STATUS_ERROR. Usually this issue disappears if we restart our camera driver. Can Nvidia provide any support as to why this may occur / any debugging steps we can conduct to determine the root cause?

Which camera module listed as supported on the following pages are you using?

If it’s supported, please provide the complete command and its full output.

We are using the Quanta HZKJ-3, and Quanta HZKK-1. The command we are running is launching our proprietary camera driver.

As mentioned on the page (https://developer.nvidia.com/drive/ecosystem-orin#camera), both the Quanta HZKJ-3 and Quanta HZKK-1 camera modules are supported by Quanta. If you encounter any issues or need additional assistance, you should reach out to them.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.