Spread Spectrum Disable on TX1

Hi Guys,

Need urgent help.
We developed a board with TX1 and add PLX PEX 8619 to it. We are not able see devices behind PLX switch.
We need to desable spread spectrum on TX1.
I am using JetPack 2.3.1 L4T 24.2.1, kernel 3.10.96.

In Kernel kode I changed USE_PLLE_SS to “0”:

drivers/platform/tegra/tegra21_clocks.c:51:#define USE_PLLE_SS 0
include/linux/platform/tegra/clock.h:29:#define USE_PLLE_SS 0 /* Use spread spectrum coefficients for PLLE */

It doesn’t help. We checked with scope and we don’t see change.

  1. Can you confirm that I am doing it right in Kernel
  2. How to disable it in Uboot?


Reference to below link.