Ssd nvme makes unusable Jetson Agx camera

Hi,

My system: Agx Xavier, 32.6.1, Leopard Imaging 6x camera adapter.

Ssd nvme Samsung Evo 1Tb.

Ssd was installed and formatted but cameras gone away from system.

After removing ssd, cameras reappear.

Somebody faced with it?

1 Like

What’s kind of SSD interface? SATA/PCIE?
It’s USB or CSI camera?
Have a check kernel message if any clue.

It is m.2 slot inside Agx carrier board. Camera adapter installed into Agx camera connector on carrier board.
Today will post dmesg.

  1. SSD NVMe 1Tb installed, cameras down:
    kernel.log (79.1 KB)

  2. SSD removed, cameras up:
    kernel2.log (78.5 KB)

Does it boot from ssd? Looks like the device tree have problem to load the sensor driver.
Have below command to dump the device tree on both case to compare it any different.

sudo dtc -I fs -O dts -o extracted_proc.dts /proc/device-tree

It boots from emmc. Will send here dt today.

I have the same problem with the e-con serialisation / deserialisation board. STURDeCAM20_CUXVR I am using Samsung 2TB 970 EVOPlus NVMIE is running on the M2 slot of the XAVIER AGX. The cameras don’t appear when SSD is in the M2 slot but appear when SSD is removed. Same for the PCIe slot using a PCIE to M2 adapter. Both devices work when using Jetpack 4.4. The device boots from eMMC.

1 Like

@vsw Were you having this issue with Jetpack 4.5? For my part, it worked well on 4.4, but 4.4 is deprecated now.

I don’t have earlier Jetpacks for ssd setup now.
So you assume that it is software issue?
May be it is power supply lines/electrical schematic problem?
Ssd slot placed under/above camera connector.

I need to move from 4.4. That is why I was wondering if 4.5 was an option. Since it was working on 4.4, I would think this is a firmware, driver, kernel issue related to the Maxim chip both are using. This problem was not present on 4.4. But it also exists on Jetson 4.6 rev.3

Here is 2 dts:
extracted_no_ssd.dts (281.8 KB)
extracted_ssd.dts (279.4 KB)

Thanks for info.

@e-conSystems What do you think could be causing this issue? Any fix?

Here is the DMESG of the working SSD install with serialisation deserialisation board and the recent one with the problem. Will be sending the Device Trees.

DMESG_Jetpack4.4_install_with_SSD_working.txt (89.1 KB)
DMESG_Jetpack4.6Rev3_install_with_SSD_notworking.txt (79.9 KB)

@SimonZhu Please help.

Could you check the tca9548@77 driver loaded before the imx477 probe when connect ssd.

How i can check it? From log?

Have tried microSD 128gb Samsung EVO and same issue.

Insert card, cameras works.
After reboot, cameras gone away.

So if any storage installed before boot then cameras failed.

Please help to fix it.

Nvidia please help.

Yes, please check the kernel log if any sequence different for the tca9548 driver and sensor driver.
Also I would suggest configure imx477 as LKM to load it after booted to system.

Redirected to Leopard Imaging support.