SSD on AGX , the mouse can't display

If I use SSD,the mouse can’t display. I need to restart it,and it will dispaly.

when I restart AGX,I get the following message.

A stop job is running for save/restore sound card state (52s / 1min 30s)
tegra-i2c c250000.i2c: —register dump for debugging
tegra-i2c c250000.i2c: I2C_CNFG - 0x22c00
tegra-i2c c250000.i2c: I2C_PACKET_TRANSFER_STATUS - 0x10001
tegra-i2c c250000.i2c: I2C_FIFO_CONTROL - 0x0
tegra-i2c c250000.i2c: I2C_FIFO_STATUS - 0x800080
tegra-i2c c250000.i2c: I2C_MST_FIFO_CONTROL - 0x700000
tegra-i2c c250000.i2c: I2C_MST_FIFO_STATUS - 0x7f0000
tegra-i2c c250000.i2c: I2C_MST_PACKET_TRANSFER_CNT - 0x0
tegra-i2c c250000.i2c: I2C_INT_MASK - 0x7C
tegra-i2c c250000.i2c: I2C_INT_STATUS - 0x2
tegra-i2c c250000.i2c: I2C_transfer timed out addr: 0x1a

Hi,

Do you mean a PCIe SSD drive on board? Please describe your problem more clearly.

Also, we need a concrete step of how to reproduce this error. You should try to give out concrete steps first.

  1. buy a " KC2000 NVMe PCIe SSD"
  2. Install it on AGX
  3. power on

and I lose the mouse cursor

  1. restart AGX and I get many message like this

A stop job is running for save/restore sound card state (52s / 1min 30s)
tegra-i2c c250000.i2c: —register dump for debugging
tegra-i2c c250000.i2c: I2C_CNFG - 0x22c00
tegra-i2c c250000.i2c: I2C_PACKET_TRANSFER_STATUS - 0x10001
tegra-i2c c250000.i2c: I2C_FIFO_CONTROL - 0x0
tegra-i2c c250000.i2c: I2C_FIFO_STATUS - 0x800080
tegra-i2c c250000.i2c: I2C_MST_FIFO_CONTROL - 0x700000
tegra-i2c c250000.i2c: I2C_MST_FIFO_STATUS - 0x7f0000
tegra-i2c c250000.i2c: I2C_MST_PACKET_TRANSFER_CNT - 0x0
tegra-i2c c250000.i2c: I2C_INT_MASK - 0x7C
tegra-i2c c250000.i2c: I2C_INT_STATUS - 0x2
tegra-i2c c250000.i2c: I2C_transfer timed out addr: 0x1a

  1. when it enter the desktop, I get the mouse cursor
  2. I shut down AGX and push the bottom let it boot up, I lose my mouse cursor again.

by the way, If I remove “KC2000 NVMe PCIe SSD”, It will resume normal operations.

Could you share the full dmesg file and the result from command lspci -vv?


image

Hi,

Please always dump the log as text file instead of picture. Thanks.

Also, you didn’t post the dmesg.

dmesg.txt (113.5 KB) lspci.txt (4.0 KB)

Hi,

This issue looks like this one.

Unfortunately, for such issue, the only solution I could think of is to put a tape on I2C lanes. But, M.2 Key-M form-factor being a tiny one, I’m not sure if you could do it.

If I try other SSD,it can be ok??
if the answer is “yes”, can you tell me which SSD is best?

The answer is yes. However, I think it is better for other forum users to recommend the SSD.

I will let them reply.