SSH hangs at login to Jetson Nano

Because I relocated my Jetson Nano to another room in the house, I needed to implement wi-fi networking. I’m using a TP-Link TL-WN725N. I have a half dozen other computers, most running Ubuntu Linux, plus one Mac, that should all access each other via ssh. When the Nano had ethernet, this was not a problem, but now I the ssh login/connection process hangs either before or after entering the password from each of the other machines. If I run the Nano from a console (normally headless), I often cannot ssh out. On the other hand, I can ping into and out of the Nano. I have tried reinstalling ssh, deleting the .ssh folder and setting up the keys again - all with no effect.

I’m running Ubuntu-MATE 18.

If I start ssh with -vvv, I get the following at the end:

debug1: Next authentication method: password
xxx@yyy's password:
debug3: send packet: type 50
debug2: we sent a password packet, wait for reply
ssh_dispatch_run_fatal: Connection to port 22: Operation timed out

Is there some ssh setting that I’ve missed?

Problem apparently solved. In the Network Connections interface there was a Docker entry that I don’t use. When I deleted that, the wi-fi SSH interface started working properly.