SSH is down

Hey everyone,

i am facing the issue, that after i updated the DrivePX2 to the version 5.0.10.3, that SSH is not working anymore. The SSH server seems to be down, i dont get any access to it anymore.
What i tried so far:

  1. I killed all the SSH processes
  2. I tried to stop/star/restart the ssh service with sudo rights
  3. I generated new SSH keys
  4. I tried to reconfigure the openssh-server

In the last try, i got the following error:

sudo dpkg-reconfigure openssh-server
Creating SSH2 RSA key; this may take some time ...
2048 SHA256:c60ShLPJC75aOh6+Kbd8et2NhlW+M3YEUyqS8G7zDbo root@tegra-ubuntu (RSA)
Creating SSH2 DSA key; this may take some time ...
1024 SHA256:VQUaFmTGXDMWxgCwjNij3eGhC+0Zxq0hy4iqbCglnSs root@tegra-ubuntu (DSA)
Creating SSH2 ECDSA key; this may take some time ...
256 SHA256:7wsmywneHn87E/8iSGSLGs8Ldk2+xGHLSwNhLzEqYos root@tegra-ubuntu (ECDSA)
Creating SSH2 ED25519 key; this may take some time ...
256 SHA256:TrgZcb/jZ5iFYUFqM/NJBmwPZFgntoQ71WFdh1O+YvY root@tegra-ubuntu (ED25519)
Unsafe symlinks encountered in /var/run/sshd, refusing.
insserv: warning: script 'S02nv-run-date' missing LSB tags and overrides
insserv: warning: script 'nv-run-once-install-gie' missing LSB tags and overrides
insserv: warning: script 'nv-run-date' missing LSB tags and overrides
insserv: warning: script 'nv-run-once-install-cuda' missing LSB tags and overrides
insserv: warning: script 'nv-run-once-install-dpx' missing LSB tags and overrides
insserv: warning: script 'nv-run-once-install-dwx' missing LSB tags and overrides
Job for ssh.service failed because the control process exited with error code. See "systemctl status ssh.service" and "journalctl -xe" for details.
invoke-rc.d: initscript ssh, action "restart" failed.
● ssh.service - OpenBSD Secure Shell server
   Loaded: loaded (/lib/systemd/system/ssh.service; enabled; vendor preset: enabled)
   Active: activating (auto-restart) (Result: exit-code) since Tue 2019-01-29 04:45:29 PST; 16ms ago
  Process: 7098 ExecStartPre=/usr/sbin/sshd -t (code=exited, status=255)

Jan 29 04:45:29 tegra-ubuntu systemd[1]: Failed to start OpenBSD Secure Shell server.
Jan 29 04:45:29 tegra-ubuntu systemd[1]: ssh.service: Unit entered failed state.
Jan 29 04:45:29 tegra-ubuntu systemd[1]: ssh.service: Failed with result 'exit-code'.

I think there is a bigger problem in my ubuntu but i have no idea why? What changed in the softwar release?
Thanks for helping me.

Dear betznxqsv,
Could you please check uninstalling ssh and re-installing it again

Hey SivaRamaKrishna,

thanks for the fast answer. Yes i did uninstall and install SSH again. I got the same problem.

Dear betznxqsv,
DrivePX2 software stack does not disturb your configuration on host. I have tested SSH connection on my host following https://www.digitalocean.com/community/tutorials/how-to-set-up-ssh-keys-on-ubuntu-1604 and accessed DrivePX2 with 5.0.10.3. I don’t see any problem at all.