ssh Jetson tx2

Does anybody know how to ssh the jetson tx2 and the linux computer so that I can use only one computer to control it instead of adding an extra monitor and keyboard/mouse. Please send me links of step by step tutorials if you have any good ones. Thanks in advance

I saw your other post, this is somewhat more detail. So basically you just need to know the address of the Jetson which the host will use to reach the Jetson. One note to be aware of before starting is that there are dotted-decimal format addresses, e.g., 192.168.1.2 is dotted-decimal, and there are also named addresses (via DNS service), e.g., devtalk.nvidia.com is a named address. To use a named address somewhere a router or DNS server must know the conversion between dotted-decimal address and named address…there is always a dotted-decimal address, and this should always be useful…the named address is optional for convenience. You must first determine the address of the Jetson in either format.

If JetPack was used to set up from a flash, you might be able to refer to a named address, e.g., “tegra-ubuntu”. If not, then you need to check router logs to see what address was assigned to the Jetso (and a PC under Linux can act as a router, JetPack may do this though a dedicated hardware router might be easier). I’m going to pretend you know your Jetson was assigned address 192.168.1.2, and that DNS has mapped this to “tegra-ubuntu”. In this case these two commands would be interchangeable for logging in to user “ubuntu” on the Jetson via command line:

ssh ubuntu@tegra-ubuntu
ssh ubuntu@192.168.1.2

If you leave out the account to log in to it’ll prompt for that, e.g., this will prompt for user name prior to password:

ssh 192.168.1.2

NOTE: Wired ethernet will be ready for an address request to a router by default. WiFi will require extra configuration.

I did install JetPack from flash.Right now I have the jetson connected to a monitor and when I open the terminal in the monitor and i type in

ifconfig

it shows me “eth0” “lo” and “wlan0” when I open the terminal in the computer where i used the flash to install the program i get “lo” and “wlp3s0” I am unsure which one im supposed to looking at for the IP address. also the name on the monitor’s terminal connected to the nvidia shows the name “nvidia@tegra-ubuntu” im assuming this is the equivalent to the “ubuntu@tegra-ubuntu” you are using in your example?

Is wired ethernet connected to your network? If so, from the Jetson, the address in eth0 would be the dotted-decimal address. The PC will be able to use this. The actual interface name on the PC won’t matter (i.e., the ifconfig ID of eth0, wlp3s0, so on…these are the “interfaces”), its use is automatic without your need to name one. The naming on the terminal is just so you know who you are logged in to…it is only coincidental that it shows “@tegra-ubuntu”…if your router is set up for this by JetPack, then “@tegra-ubuntu” and dotted-decimal version of the eth0 address looking like “@192.168.1.2” (or similar) are interchangeable (what show on your command line when logged in is customizable, the default sets to your network named address…this could change without networking changing). Substitute the actual eth0 address, then try both “ssh nvidia@192.168.1.2” and “ssh nvidia@tegra-ubuntu”. This should allow entering a password.

Note that you always have a login name, and a login address. They are separated by “@”. “ubuntu@” implies user ubuntu, “nvidia@” implies user nvidia. “@192.168.1.2” (assuming this is what eth0 is) would be equivalaent to “@tegra-ubuntu” if DNS was set up. The “@192.168.1.2” should always work, the “@tegra-ubuntu” is optional depending on environment.

It seems that you want to establish ssh session from Host OS to Jetson.

  1. you need to know ip address of Jetson or a network name, but in your case it would be rather ip address than a network name. You may get it running ifconfig from jetson. Once Jetson address is determined you could establish ssh terminal connection from the Host computer.

  2. ssh username@address

  3. I would also add key based authorization for you do not need to use passwords.

-) you generate a keypair at Host computer and copy content of the file /home/username/.ssh/id_rsa.pub
and you paste the content to the Jetson /home/username/.ssh/authorized.keys file
-) now you should be able to connect without password prompt

Reference.
https://help.github.com/articles/connecting-to-github-with-ssh/

I tried to ssh but then it asks me for a password. I have not changed the default passwords so I was assuming the password was either nvidia or ubuntu and it says permission denied. any suggestions?

Do you state username explicitly when ssh?

I am typing

ssh nvidia@tegra-ubuntu

if you are doing so from the nvidia tegra itself then it is an equivalent of ssh@127.0.0.1

you shall try ssh with ip address, if you are connecting from other machine

you may copy-paste the output to there for analysis.

you may as well change and set a password at jetson with passwd command

Sorry Im confused. If I am trying to ssh from the computer that I installed the Jetpack documentation to the Jetson which is connected to a monitor (right now) Should i do this from the terminal in the monitor or the one in the computer?

It seems that you are connecting via ssh from Host OS.
You should determine the ip address of the Jetson computer first. You may do that with executing ifconfig at the Jetson.

Once you know the ip address of the Jetson you may execute

ssh nvidia@ip-address-of-the-jetson

if that wont work - make sure that you are using a correct password

you may explicitly set password from Jetson with

passwd username

I did. I got the IP address from the Jetson, but now when i ssh it should I type the command in the terminal on my computer? i.e. if my ip address is 192.168.1.2 should i just execute

ssh ubuntu@192.168.1.2

?

you may try either nvidia@192.168.1.2
or any other user registered at the system including ubuntu

do you mean that the jetson ip address is 192.168.1.2?

My question as well…if 192.168.1.2 is the PC, then this will go to that account on PC…if 192.168.1.2 is the Jetson, then it will do as expected.

Well I got the IP address of the Jetson and i have tried ssh to it from my computer by typing

ssh nvidia@tegra-ubuntu

also by typing

ssh ubuntu@tegra-ubuntu

also by typing

ssh ubuntu@IPADDRESS

also by typing

ssh nvidia@IPADDRESS

(replacing IPADDRESS by the ip address of course) but it asks me for a password. I have not changed the default password which should be nvidia because when i downloaded packages into the jetson i used that password and it worked. unless i am mistaken and i need to create a password? or is there a way that i can figure out which password it wants?

Thanks so much again!