Starfield does not launch on most NVIDIA GPUs on Linux, and not at all on Pascal GPUs

No change for me in 545.29.02 compared to 545.23.06 as reported here. The game is broken and completely unplayable on Ampere.

The latest Vulkan beta 535.43.16 does fix the game, but the frame rate remains less than half of what you get on Windows, all other things equal: e.g. 40 fps (Proton Experimental bleeding-edge) vs 80-90 fps (Windows 10) on 1080p, Ultra, FSR 100%, New Atlantis MAST, 3080 12GB.

It seems that the Linux driver is still not very well optimized.


Why do you use fsr while having dlss? The game looks much better with dlss.

I’m reporting the frame rate with FSR because that’s what I tested on Windows. I’ll probably retest it once the new patches land in the non-beta SF, as there seem to be other optimizations too, and it’s important to have comparable results.

Need Nvidia Reflex!

Same here, Starfield runs much better with the latest Vulkan beta driver, 535.43.16, and up to date VKD3D. I can get 60 FPS rather often on a 4080, IF I use the DLSS mod and about 70% scale. Kinda similar on FSR to be honest. Using the latest DLSS dll.

Game has a beta that has DLSS natively, so no need for a mod there.

1 Like

Keep an eye on these.

1 Like

Returning with a 4090 - just the same result - bad performance and FPS is the same as with GTX 1080Ti. The main difference is:
1080Ti is 99% utilized and 4090 is 50-60% utilized but the FPS is the same between the two cards- 35-35 and rarely 50 FPS no matter the settings.
For now I’m using 535.43.16 but there’s no really performance difference between the recent versions.


Two updates from my side on a 3080 12GB.

  • At some point Starfield has started working on 545.29.02. That was before SF’s beta and with Proton Experimental bleeding-edge, so probably due to some change in vkd3d.
  • Proton/Windows comparison with latest SF and 545.29.02,1080p, Ultra, DLSS/DLAA, New Atlantis MAST entrance (the flags area): 43-45 fps Proton vs 75-80 fps Windows.

So, while the game is now generally playable, there are still serious problems with the performance on Linux as others are noting too.

4070Ti - Ubuntu 22.04
After months of frustration, major nvidia update in main sudo apt update channel and … Wow! Full starfield at 3K ultra res no stutter, smooth.
nvidia-smi says 545.29.06 (like I said, huge update, dozens of nvidia files…)
(Edit - I had mistakenly posted 530… was logged in to wrong machine, above is correct)
using steam with experimental, YMMV

Pretty much what everybody else said. I find that it’s pretty flawless on medium using balanced as your DLSS setting. Though on my rig it really should be flawless on Ultra everything. It is a gaming laptop after all.

Edit: Also I had to switch to Proton Experimental. I’m not sure what the cause is but at some point after the SF update to natively include DLSS or maybe a VKD3D or Nvidia driver or Proton GE change SF started crashing when I takeoff on a ship with Proton GE.

It’s the game update. I used the same drivers, the same Proton and VKD3D versions and the game now runs much better after the update. The problem is still in the driver though.

The game update did improve the framerate a bit, yes: about 5 fps on Proton and probably around 5-10 fps on Windows in my tests. As for the game starting running again with DGCC, that really couldn’t have been because of Starfield’s update. As mentioned, I noticed it running even on pre-beta Starfield, which is why I assume it must have been a change on Proton/vkd3d side (as bleeding-edge gets updated almost daily).

Anyway, the fact remains that we still have around 50% of Windows performance on Proton, which is really a shame. It’s generally playable on a 3080 12GB even on Ultra without upscaling, though not too enjoyable. But I can feel the pain of those with more modest hardware. I do hope whatever is the cause of that underperformance to be solved soon.

1 Like

Using vulkan dev 535.43.19 i have a horrible frametime and graphics issues, steam proton experimental bleeding edge, ryzen 5800x, 32 GB ram, rtx 3070, lg 1440p 165 hz, manjaro linux kde, ultra settings with dlss on quality vrs off at 1440p.

steam-1716740.log (2.8 MB)

1 Like