Steam GTA Definitive Edition Crashing

Very intermittent. GTAIII and GTAVC. Game will periodically “stutter” a bit. During a stutter, 1% of the time it will crash. Will have to wait 5 minutes or so to regain control. Sometimes will end up in X Window, sometimes original login console, sometimes need to ssh in and force a power down. I ran and will attach the output. I think the xid errors related to this issue are the following:

NVRM: Xid (PCI:0000:01:00): 8

Any help appreciated!

nvidia-bug-report.log.gz (981.4 KB)

Just adding more info. Here is a portion of Xlog.0.log:

[ 47780.154] (WW) NVIDIA: Wait for channel idle timed out.
[ 47783.155] (EE) NVIDIA(GPU-0): WAIT (2, 8, 0x8000, 0x0000c97c, 0x0000c984)
[ 47790.155] (EE) NVIDIA(GPU-0): WAIT (1, 8, 0x8000, 0x0000c97c, 0x0000c984)
[ 47801.170] (EE) 
[ 47801.171] (EE) Backtrace:
[ 47801.171] (EE) 0: /usr/libexec/Xorg (xorg_backtrace+0x40) [0x587f60]
[ 47801.171] (EE) 1: /usr/libexec/Xorg (0x400000+0x18b8d9) [0x58b8d9]
[ 47801.171] (EE) 2: /lib/ (0x7f54c7d1a000+0x125a0) [0x7f54c7d2c5a0]
[ 47801.171] (EE) 3: /usr/lib/xorg/modules/drivers/ (0x7f54c63eb000+0xda5e0) [0x7f54c64c55e0]
[ 47801.171] (EE) 4: /usr/lib/xorg/modules/drivers/ (0x7f54c63eb000+0xdb136) [0x7f54c64c6136]
[ 47801.171] (EE) 5: /usr/lib/xorg/modules/drivers/ (0x7f54c63eb000+0xde8c9) [0x7f54c64c98c9]
[ 47801.171] (EE) 6: /usr/lib/xorg/modules/drivers/ (0x7f54c63eb000+0xdea49) [0x7f54c64c9a49]
[ 47801.171] (EE) 7: /usr/lib/xorg/modules/drivers/ (0x7f54c63eb000+0xd6513) [0x7f54c64c1513]
[ 47801.171] (EE) 8: /usr/lib/xorg/modules/drivers/ (0x7f54c63eb000+0xd8a95) [0x7f54c64c3a95]
[ 47801.171] (EE) 9: /usr/lib/xorg/modules/drivers/ (0x7f54c63eb000+0xd5a8c) [0x7f54c64c0a8c]
[ 47801.171] (EE) 10: /usr/lib/xorg/modules/drivers/ (0x7f54c63eb000+0xda8d1) [0x7f54c64c58d1]
[ 47801.171] (EE) 11: /usr/lib/xorg/modules/drivers/ (0x7f54c63eb000+0xdb136) [0x7f54c64c6136]
[ 47801.171] (EE) 12: /usr/lib/xorg/modules/drivers/ (0x7f54c63eb000+0xf0e86) [0x7f54c64dbe86]
[ 47801.171] (EE) 13: /usr/lib/xorg/modules/drivers/ (0x7f54c63eb000+0xd23fe) [0x7f54c64bd3fe]
[ 47801.171] (EE) 14: /usr/lib/xorg/modules/drivers/ (0x7f54c63eb000+0x45f310) [0x7f54c684a310]
[ 47801.171] (EE) 
[ 47801.171] (EE) Segmentation fault at address 0x34
[ 47801.171] (EE) 
Fatal server error:
[ 47801.172] (EE) Caught signal 11 (Segmentation fault). Server aborting
[ 47801.172] (EE) 
[ 47801.172] (EE) 
Please consult the The X.Org Foundation support 
 for help. 
[ 47801.172] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[ 47801.172] (EE) 

It seems to run okay on the same machine under Windows 10 with the nvidia driver 537.13. A lot less stuttering there, but to be fair that is on an ssd, and I want to leave that dedicated to the Windows install for now. I’ll keep playing on Windows and see if it ever crashes there.

Still going strong with windows. I looked up Xid 8 and got this info:

Xid: 8
Failure: GPU stopped processing
Driver Error: X
User App Error: X
Bus Error: X
Thermal Issue: X

Is there somewhere I can get help with this? Are there any nvidia support forums or anything where I can get help?

Still need help with this.

Any debugging tips would be appreciated.

Any help appreciated. I see a lot of folks having problems with nvidia-smi, but mine appears to be working fine. GTA III/VC never did crash on windows using 537.13, but they still crash a lot under linux/steam. I think I may be shadow banned, so if someone could reply that would be great.

Absolutely pathetic. Just like Blizzard. Just absolutely struggling and incapable of supporting their products. Struggling to stay just above water, sucking in lung fulls of water. I guess an era is over.

Hello there,
would it be possible to provide more information, I can see that you are using a little bit older version of the driver 535.43.02, have you tried updating it either to latest vulkan dev or even the stable(535.104.05) ?
In addition what are your system specs, as I played a lot through the game and haven’t experienced a single crash ever.
Does the same problem occur if you try different proton versions, changed in game settings ?

Thanks for the reply. I’ve been using many versions of the nvidia drivers. Currently I’m using 535.104.05 but was using earlier versions seeking stability. I don’t use debian or apt(LFS) so I have installed from source vulkan1.3.250.1, and vkd3d 1.8. CPU/GPU are older but shouldn’t crash like this: i7-5930K with 64GB and Titan X Pascal. Yep, should be a driver issue since it works fine in Windows. I’ve tried many permutations with the settings. It will crash at 30fps at lowest settings with everything turned low or off. It will play fine at all max settings and crash at the same rate as the lowest settings. Monitor is at 144, so tried 144, 72, 60, 30 hertz.

I just finished getting all achievements on GTA3 and GTAVC with the Windows boot(don’t care for SA), so I’m not playing currenlty, so don’t care as much now until I run into the next thing. It might even just be I need to use the SSD instead of the HDD but that is not an option right now. Once again, thanks for replying!

ETA: I just noticed one weird thing. Trying to verify my main memory, the records show I bought and installed 32GB(don’t want to open it up now), but when I use memory reporting methods like “grep MemTotal /proc/meminfo” and “free -m” it seems to report that I have 48GB, but that doesn’t make sense. Weird.

ETA2: Looking at my records further, I have 64GB installed, I guess it is only recognizing 48GB for some reason. I think I can fix with bios settings…

ETA3: Yep! Specifying frequency in bios, now seeing whole 64GB. It’s not related to the crashing issue, but is more important! 16GB wasted for years! Thanks kodatarule, you are the person!

Which distro are you currently running, also my vulkan icd is 1.3.262-1 on endeavouros. As for the game it should run on DXVK without issues.
At what time approximately does the crash occur ? However me and a friend(rtx 3090 and rtx 3080) both haven’t had a single crash issue with the definitive collection.

Yes, it is possible that a different version will work and I will try that. It’s the best route for me. But since I have to build from source, I want to be careful about the path I take. It should be possible to debug this issue and point to the culprit.

Hardware failure.
Driver failure.
Application failure.

I work with this kind of stuff and I can inspect coredumps and run things through a debugger, but I don’t know the domain. A domain expert i.e. an nvidia employee or a vulkan developer, should be able to figure it out without too much effort.

What I fear is that they are not accounting for my specific card in the driver, which isn’t a mass produced popular one. I’ve run into this before when my card wasn’t coming back from sleep correctly and most other cards were. I think I had to live with that issue for like a year. I already saw another post saying a new game doesn’t work with pascal architecture based cards, which is what mine is.

I have seen messages that point to a dxvk thing which may point my vulkan version. Maybe I’ll give 1.3.262-1 a go. If so, I’ll post for posterity.

Also, if it’s just that my hdd is too slow and not keeping up, then I wouldn’t bother with any of this. I have a hunch if I moved to ssd it may stop. I just can’t do that right now.

I wouldn’t rule out the possibility of the specific GPU being how it behaves with the driver, so it seems like it(I’ve seen weird cases with other linux users with other gpus where they didn’t experience specific issues while I did).
For this specific case, maybe try latest dxvk, make sure that the game loads nvapi, try different proton. I don’t think just updating the vulkan icd would change much.

Well that was one of my first questions. Since I’m playing via Steam, is dxvk built into their wine version?

I’ve run into problems before when I’ve used dxvk with wine-vkd3d. Before I was building wine-vkd3d myself I had to use dxvk it would change WoW from 15 fps to 100fps. But ever since I’ve been building vkd3d myself, if I use dxvk it would make things worse.

But this is good. If I run a game via steam, I know it is using my nvidia driver which is dependent upon the vulkan library. But I’m not sure about vkd3d and dxvk and whether it would use my libraries(dynamic) or if Steam’s wine is built with vkd3d and dxvk embedded(static).

As a matter of fact it gets more “confusing”. Proton has their own version of vkd3d, but that is hard for me to build. But it works with a lot of games that wine’s version doesn’t. Diablo IV is a good example.

I believe I’ve seen evidence that dxvk is included statically within Steam’s wine-proton version?

What I understand
vkd3d = dx12 on vulkan, dx9, dx10, dx11 on opengl
dxvk = dx9, dx10, dx11 on vulkan

Oh yeah, when I rebuild different versions of vulkansdk, it also builds a library file like So it wouldn’t be just changing the icd, it changes the underlying driver too, although it might use older versions of various components. At least that’s the way I understand it. So if Steam’s wine(-proton) has vkd3d-proton and dxvk statically linked, that leaves only vulkan(and nvidia). But I don’t know that yet. I build both 64 and 32 bit versions.

Thanks for helping me.

Proton and ProtonGE Ship dxvk and vkd3d so no need for you to build anything or put anything. In particular the GTA definitive runs on dx11, so it should use dxvk. Maybe you can toggle mangohud and check if it’s correctly using it ?

Well, except for the vulkan library, that needs to be built and installed. Okay, so if the games use dx11, normal wine would use opengl. So I guess Steam’s wine has dxvk built in and is using that for dx11. So it seems the only points of failure are my vulkan install, the nvidia driver, and/or the hardware(hdd too slow?, need ssd?). It could be nvidia’s driver not accounting for my specific card. It could be a “bug” in the specific vulkan version, or it could be something wrong with my install of vulkan 1.3.250. I have no idea what mangohud is.

Mangohud is basically an overlay(it is also built into gamescope for steam deck) you can check their github page.
So in regular circumstances the game would ideally run on dx11 through dxvk(thus using vulkan) and performance should be very similar - identical, worse or better to how it runs on windows. I also run the collection from an old HDD and it has been running fine, the only thing might really be vulkan icd loaders, but I’m on rolling distro so pretty much everything gets updated, including drivers at rapid pace.
I would first check to confirm if the game is running through dxvk(and not WINED3D/OpenGL) and then if it isn’t, to fix that and re-test. In case that it has been using dxvk, most likely just to rule it out I would check if it’s possible to update the vulkan icd loaders to the latest version.

Cool, I’ll take a peak at mangohud. Also good to be able to cross off the hdd from the list, thanks. It seems to be using dxvk, these are found in the steam logs:

err: DxvkSubmissionQueue: Command submission failed: VK_ERROR_DEVICE_LOST

Googling that and trying the various fixes for it did not help. It’s a bit of work, but I’ll probably forge ahead and install the latest version of vulkan.