Stmanalyze tool error. "Cant find STM header"

Please provide the following info (tick the boxes after creating this topic):
Software Version
DRIVE OS 6.0.8.1

Target Operating System
Linux

Hardware Platform
DRIVE AGX Orin Developer Kit (940-63710-0010-300)

SDK Manager Version
1.9.3.10904

Host Machine Version
native Ubuntu Linux 20.04 Host installed with DRIVE OS Docker Containers

This error occurred when I tried use “stmanalyze” tool with log files created with “Launcher” binary, with custom build sample app.
I am not sure which .log file to be used with -l i tried with all the files generated.
Has some tried this tool with log files generated from launcher binary?

/usr/local/driveworks/bin/launcher
–binPath=/usr/local/driveworks/bin
–spec=/home/nvidia/applocationpath/sampleTest5.app.json
–logPath=/home/nvidia/applocationpath/src/cgfTest5Cpp/logSpace
–dwdatapath=/usr/local/driveworks/data
–schedule=/home/nvidia/applocationpath/sampleTest5__standardSchedule.stm
–start_timestamp=0
–loglevel=DW_LOG_DEBUG
–fullscreen=1 --winSizeW=1280 --winSizeH=800 --disableStmControlLogger=1
–gdb_debug=0 --app_parameter= --useLCM=0
–datapath=/usr/local/driveworks/data/samples/cgf/trafficlightturning-hyperion8
–mapPath=
–path=/home/nvidia/applocationpath
–virtual=0 > /home/nvidia/applocationpath/logSpace/launcher.log 2>&1

“logspace” folder generated log files are as follows:
launcher.log
mainClient_0.log
schedule_manager_0.log
ssm.log
stm_master.log

error: AssertionError: Cant find STM header, found “[STM] Opening NvSciIpc endpoints” instead

Thank you.

Dear @sushant.bahadure,
Could you add --log in app.json file like in below snippet and use Use the stm-bin_XXXX.log as input to stmanalyze tool

 "stm_master": {
            "runOn": "machine0",
            "executable": "stm_master",
            "argv": {
                "--timeout-us": "80000000",
                "--soc": "TegraA",
                "-m": true,
                "--log": "stm-bin.log"
            }
        },

Hi @SivaRamaKrishnaNV,

thank you for the suggestion,

I had used “–log”: “stm_sreport” by default, appending .log as “stm_sreport.log” generateslog file which can be used by the tool.

Thank you.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.