Strange Bug cannot find cause...

Hi, just wondering if anyone could possibly give me any ideas as to how to fix a weird problem i’m having or what might be causing it?

My problem is that whenever I do a fourier transform or inversefourier, only one out of every 2 succeeds. Everything thing else I do works perfectly fine. Also fourier transforms on small arrays always work everytime. They only fail when I get to about 1000x1000.

Just so you are aware this is using CUDA support in Wolfram Mathematica 8 so the problem could lie with them but I don’t think it does. I think I have messed something up specifically on this machine. The thing that is confusing me is that up until a few days ago it worked perfectly fine, and I can’t think of anything I have changed. The codes all work fine on other computers aswell so there isn’t really a problem there, I’ve tested on 3 different computers.

So can anyone think of anything that could cause my to receive a kernel launch failure precisely 50% of the time?

And if not any suggestions as to what I could try to get back to how it used to be? I could reinstall Mathematica, graphics card drivers, cuda toolkit I guess. I don’t really fancy reformatting my entire machine just to fix it…

Thanks :)

edit: On a potentially related sidenote, i have just tried to update the nvidia drivers from 263.09 to 266.58 and I can’t. It fails trying to install the graphics driver :(