Strange compile bug - setup problem? Parse error 9? What?

Under Windows XP (32 bit), I successfully built and tested a CUDA application, using Visual Studio 2005 on my work machine. I can only use device emulation mode (laptop with ATI chipset), but it compiles and works just fine.

Move the project to my home machine, same version of Visual Studio 2005 (Version 8.0.50727.762 SP.050727-7600), but this machine has a NVIDIA 9600 card. Same version of Windows XP. Both machines have the same CUDA version. (Version 2.3).

I get this error whenever I try and compile any CUDA code.

Parse Error 9

Visual Studio is generating the following command line;

“F:\CUDA\bin\nvcc.exe” -ccbin “c:\Program Files\Microsoft Visual Studio 8\VC\bin” -deviceemu -c -D_DEBUG -DWIN32 -D_CONSOLE -D_MBCS -Xcompiler /EHsc,/W3,/nologo,/Wp64,/Od,/Zi,/MTd -I “F:\CUDA\include” -I ./ -o Debug\CUDAWarpFull.obj CUDAWarpFull.cu

Going in by hand in a command window, I’ve removed each option. Eventually I got down to trying to compile a file which has nothing in it but including <cuda.h>, and I get the same problem. And cuda.h is identical to the one on my laptop.

I tried re-installing the toolkit, SDK, and drivers. I haven’t gotten to the point of re-installing VS 2005, yet.

Does anyone have any experience with this problem? What does the error mean? I’m almost certain it’s some kind of setup or configuration problem - but I’m running out of ideas. I’m so close to testing on real hardware, and this is REALLY frustrating.

Any help is greatly appreciated.

Hoping someone can help if I can provide a little more information.

I turned on verbose and captured the output. I’m pretty convinced it’s a enviroment variable setting, but I’m not sure where to look;

Here’s the output - hopefully someone can make some sense out of what I’m doing wrong. Thanks in advance.

F:\Tools\Rotate\Rotate>“C:\CUDA\bin\nvcc.exe” -v -ccbin “c:\Program Files\Micros
oft Visual Studio 8\VC\bin” -deviceemu -c -D_DEBUG -DWIN32 -D_CONSOLE -D_MBCS -X
compiler /EHsc,/W3,/nologo,/Wp64,/Od,/Zi,/MTd -I “C:\CUDA\include” -I ./ -o Debu
g\CUDAWarpFull.obj CUDAWarpFull.cu
# _SPACE_= # MODE=EMULATE
# _HERE_=C:\CUDA\bin # THERE=C:\CUDA\bin
# _TARGET_SIZE_= # TOP=C:\CUDA\bin/…
# PATH=C:\CUDA\bin/../extools/bin;C:\CUDA\bin/../open64/bin;C:\CUDA\bin/../bin; C:\CUDA\bin/../lib;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\system32\WBEM;C:\Pr ogram Files\Microsoft Visual Studio 8\VC\bin;C:\Program Files\Microsoft Visual S tudio 8\Common7\IDE;E:\3dsmax5\backburner2\;C:\Program Files\Common Files\Autode sk Shared\;C:\Program Files\Microsoft SQL Server\90\Tools\binn\;F:\Program Files \Subversion\bin;C:\Program Files\QuickTime\QTSystem\;C:\CUDA\bin;F:\Program File s\OpenVPN\bin # INCLUDES="-IC:\CUDA\bin/…/include" “-IC:\CUDA\bin/…/include/cudart”
# LIBRARIES= "/LIBPATH:C:\CUDA\bin/../lib" cudart.lib # CUDAFE_FLAGS=
# OPENCC_FLAGS= # PTXAS_FLAGS=
# VSINSTALLDIR=c:/Program Files/Microsoft Visual Studio 8/VC/bin/../.. # VCINSTALLDIR=c:/Program Files/Microsoft Visual Studio 8/VC/bin/…/…
#$ c:/Program Files/Microsoft Visual Studio 8/VC/bin/…/…/common7/Tools/vsvars3
2.bat

F:\Tools\Rotate\Rotate>call C:\DOCUME~1\rsybel\LOCALS~1\Temp/tmpxft_0000136c_000
00000-2.bat
Setting environment for using Microsoft Visual Studio 2005 x86 tools.

F:\Tools\Rotate\Rotate>set 1>C:\DOCUME~1\rsybel\LOCALS~1\Temp/tmpxft_0000136c_0
0000000-1
# DevEnvDir=c:\Program Files\Microsoft Visual Studio 8\Common7\IDE # FrameworkDir=c:\WINDOWS\Microsoft.NET\Framework
# FrameworkSDKDir=c:\Program Files\Microsoft Visual Studio 8\SDK\v2.0 # FrameworkVersion=v2.0.50727
# INCLUDE=c:\Program Files\Microsoft Visual Studio 8\VC\ATLMFC\INCLUDE;c:\Progr am Files\Microsoft Visual Studio 8\VC\INCLUDE;c:\Program Files\Microsoft Visual Studio 8\VC\PlatformSDK\include;c:\Program Files\Microsoft Visual Studio 8\SDK\v 2.0\include;E:\Program Files\Microsoft SDK\Include;E:\Program Files\Microsoft Vi sual Studio .NET 2003\SDK\v1.1\include;E:\Program Files\Microsoft Visual Studio .NET\FrameworkSDK\include;C:\Program Files\Microsoft Visual Studio 8\VC\include; C:\Program Files\Microsoft Visual Studio 8\VC\atlmfc\include # LIB=c:\Program Files\Microsoft Visual Studio 8\VC\ATLMFC\LIB;c:\Program Files
\Microsoft Visual Studio 8\VC\LIB;c:\Program Files\Microsoft Visual Studio 8\VC
PlatformSDK\lib;c:\Program Files\Microsoft Visual Studio 8\SDK\v2.0\lib;E:\Progr
am Files\Microsoft SDK\Lib;E:\Program Files\Microsoft Visual Studio .NET 2003\SD
K\v1.1\Lib;E:\Program Files\Microsoft Visual Studio .NET\FrameworkSDK\Lib
# LIBPATH=c:\WINDOWS\Microsoft.NET\Framework\v2.0.50727;c:\Program Files\Micros oft Visual Studio 8\VC\ATLMFC\LIB # Path=c:\Program Files\Microsoft Visual Studio 8\Common7\IDE;c:\Program Files
Microsoft Visual Studio 8\VC\BIN;c:\Program Files\Microsoft Visual Studio 8\Comm
on7\Tools;c:\Program Files\Microsoft Visual Studio 8\Common7\Tools\bin;c:\Progra
m Files\Microsoft Visual Studio 8\VC\PlatformSDK\bin;c:\Program Files\Microsoft
Visual Studio 8\SDK\v2.0\bin;c:\WINDOWS\Microsoft.NET\Framework\v2.0.50727;c:\Pr
ogram Files\Microsoft Visual Studio 8\VC\VCPackages;C:\CUDA\bin/…/extools/bin;C
:\CUDA\bin/…/open64/bin;C:\CUDA\bin/…/bin;C:\CUDA\bin/…/lib;C:\WINDOWS\system
32;C:\WINDOWS;C:\WINDOWS\system32\WBEM;C:\Program Files\Microsoft Visual Studio
8\VC\bin;C:\Program Files\Microsoft Visual Studio 8\Common7\IDE;E:\3dsmax5\backb
urner2;C:\Program Files\Common Files\Autodesk Shared;C:\Program Files\Microsof
t SQL Server\90\Tools\binn;F:\Program Files\Subversion\bin;C:\Program Files\Qui
ckTime\QTSystem;C:\CUDA\bin;F:\Program Files\OpenVPN\bin
# PATH=c:/Program Files/Microsoft Visual Studio 8/VC/bin;c:\Program Files\Micro soft Visual Studio 8\Common7\IDE;c:\Program Files\Microsoft Visual Studio 8\VC\B IN;c:\Program Files\Microsoft Visual Studio 8\Common7\Tools;c:\Program Files\Mic rosoft Visual Studio 8\Common7\Tools\bin;c:\Program Files\Microsoft Visual Studi o 8\VC\PlatformSDK\bin;c:\Program Files\Microsoft Visual Studio 8\SDK\v2.0\bin;c :\WINDOWS\Microsoft.NET\Framework\v2.0.50727;c:\Program Files\Microsoft Visual S tudio 8\VC\VCPackages;C:\CUDA\bin/../extools/bin;C:\CUDA\bin/../open64/bin;C:\CU DA\bin/../bin;C:\CUDA\bin/../lib;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\syste m32\WBEM;C:\Program Files\Microsoft Visual Studio 8\VC\bin;C:\Program Files\Micr osoft Visual Studio 8\Common7\IDE;E:\3dsmax5\backburner2\;C:\Program Files\Commo n Files\Autodesk Shared\;C:\Program Files\Microsoft SQL Server\90\Tools\binn\;F: \Program Files\Subversion\bin;C:\Program Files\QuickTime\QTSystem\;C:\CUDA\bin;F :\Program Files\OpenVPN\bin # cl -D__CUDA_ARCH__=100 -nologo -E -TP -DCUDA_FLOAT_MATH_FUNCTIONS -DCUDA_NO_S
M_11_ATOMIC_INTRINSICS -DCUDA_NO_SM_12_ATOMIC_INTRINSICS -DCUDA_NO_SM_13_DOUBLE_
INTRINSICS “-IC:\CUDA\bin/…/include” “-IC:\CUDA\bin/…/include/cudart” -I. -
D__DEVICE_EMULATION__ -D__CUDACC__ -C /EHsc /W3 /nologo /Wp64 /Od /Zi /MTd -I "
C:/CUDA/include" -I “./” -D “_DEBUG” -D “WIN32” -D “_CONSOLE” -D “_MBCS” -FI “cu
da_runtime.h” > “C:\DOCUME~1\rsybel\LOCALS~1\Temp/tmpxft_0000136c_00000000-6_CUD
AWarpFull.cpp1.ii” “CUDAWarpFull.cu”

–error 0xffffffff –

Parse Error 9

how about removing -deviceemu option since 9600 card supports GPU computation?

I’ve removed that option - tried most everything.

I finally built the object code on my work machine, and kept the build files. I was able to extract the batch file commands.
I’m writing a batch file to do the compile, it’s mostly working.

What I’ve found so far is that the PATH environment variable is giving it problems. Maybe it’s too long. I’ll play around with that see if I can find out if it’s length, some specific syntax, or something else. Then I’ll post back.