Stuck at IP address when installing jetpack


I got stuck at the IP address when installing jetpack. Tried carrying out post installation to no avail. Also tried creating WiFi access point on nvidia jetson tx2 using both network manager and hostapd still didn’t work. Need help in these areas. I used DHCP when installing jetpack because I don’t have a route.

Thanks in advance

Can you log in locally to the TX2 and find the output of “ifconfig”? If so, then you can find the IP address that way…and the JetPack console or a pop-up will allow entering that. Once the IP address is needed the Jetson is no longer in recovery mode, and the USB cable is no longer used. As a result it implies you can run JetPack at any time with nothing but ethernet connected to work on extra packages. The big trick is that the IP address is only reported automatically to JetPack after a flash…any later run requires you to enter the address manually. Flash itself only understands wired, and thus there is no way to use WiFi for this step.

On the other hand, you can try to use WiFi (not officially supported) if you have manually gone in and set up WiFi. Regardless of if you use wired or WiFi you should be able to do the following, and if the following work, then install packages after telling JetPack the address:

  • Ping the address.
  • ``` ssh nvidia@ ```

Was able to resolve the area of ip but got stuck again where it’s says. “Error: CUDA is not O’Malley on this device” and says something about apt-get. What should I do here.

That is an odd error. Which JetPack version are you using? Does anyone at NVIDIA know why it might want “O’Malley”?

Laughs* that was a typo. Resolved that too but unable to upgrade pip when trying to run cannydectection as a test. Had to troubleshoot all day with no result.
It’s no module like cv2 and the root cause is updating pip. Why do I do here.

Apologies about O’Malley

So is the actual problem still one of needing the IP address during install of software? If so, then is it possible to log in to the TX2 and run “ifconfig” to find the address? Following that there should be a (possibly subtle) console prompt or pop-up to enter that at.

Or…was this actually narrowed down specifically to a pip install?

No the IP address problem has been solved. The pip is what I am currently facing. It’s requesting I upgrade to a much current version 19 from 8.1.1 using pip upgrade input code but I keep getting an error about main. It’s really slowing me up. Need help. Thanks

I don’t know much about the Python pip update (there are lots of pip update/install questions, but I’m not equipped to answer those). That’s probably a different topic, and although someone who knows the answer will eventually read this thread I will suggest adding a new thread for that specific topic to get a faster reply. Meanwhile, if anyone sees this and knows about the pip update error, please join the thread. :)

Okay, I’ve been able to solve the part of pip but need assistance in turning jetson tx2 to a hotspot/access point. I’ve checked the threads all through and seen not much that works step by step because I believe this a delicate procedure and need help here - turning nvidia jetson tx2 WiFi to a hotspot/access point.

I stay away from WiFi, and can’t be of much use for that. This too would probably need to be a new thread to get the right people to see it (and I’m the wrong guy to answer WiFi questions). You would want to start by mentioning what you’ve already tried.

Okay I will open another thread for this. Do also refer me to threads where the above problem has been implemented successfully. Thanks