Stuck on login loop after installing nvidia-driver ParrotOS 5.1

Stuck on login loop after installing nvidia-driver ParrotOS 5.1

Hi there,
So my problem is when I boot in default i have access to the login GUI like normally, I type my password and when I hit enter the screen goes black like if it was turned off and blink black to reload the login GUI and this sequence loop forever.

The last things I did was trying to install nvidia-driver to try if I could run a steam game on my pentest machine, sight terrible idea …

Right after starting the game i wanted to try all 3D stuff in the game was just a black screen and i find out that to apply changes i had to reboot my computer. So I did and had this issue for 2 days now.

I’m trying to find solutions on internet but don’t really find else than people giving up.

For now I can do is booting in recovery mode as root and in text mode with my primary account.
I’m absolute garbage at drivers/hardware so i don’t wanna mess up my computer more than i already did so I’m counting on anyone that can help me.
If needed I can provide all informations on my computer and hardware.

Thanks really much by advance to anyone who will read until there and try to help me.

Some specification :

Parrot version in use: Parrot OS 5.1 (Electro Ara) x86_64
Kernel version: 5.18.0-14parrot1-amd64
Shell: bash 5.1.4
Terminal: /dev/tty3
CPU: Intel Xeon E3-1241 v3
GPU: NVIDIA GM107GL [Quadro K2200] (rev a2)

Please run as root and attach the resulting nvidia-bug-report.log.gz file to your post.
Switch to vt (ctrl+alt+f3) after trying to log in. Log in on text console.
If you have internet connection, you can use pastebinit to upload it from console.

  • install pastebinit (sudo apt install pastebinit)
  • unzip logfile (gunzip nvidia-bug-report.log.gz)
  • upload logfile (pastebinit -i nvidia-bug-report.log)
  • note down and post the url you’re given

(post deleted by author)

I have my nvidia-bug-report.log but when i try to send it i have <urlopen error [Errno32] Broken pipe

edit :
@generix i finally managed to get it here :

Seems the user session is segfaulting for unknown reasons.
Which DM are you using, gdm/lightdm,?
Please post the output of
ls -l /dev/nvidia*

cat /etc/X11/default-display-manager

returned /usr/sbin/lightdm


ls -l /dev/nvidia*


crw-rw-rw- 1 root root 195,    0 25 août 19:38 /dev/nvidia0
crw-rw-rw- 1 root root 195,  255 25 août 19:38 /dev/nvidiact1
crw-rw-rw- 1 root root 195,  254 25 août 19:38 /dev/nvidia-modeset

total 0
cr-------- 1 root root 246, 1 25 août 20:30 nvidia-caps1
cr--r--r-- 1 root root 246, 2 25 août 20:30 nvidia-caps2

Looks normal. What kind of user session are you starting?
Please run
sudo journalctl -b0 >journal.txt
and paste it.

i’m logged as a normal user, the only one i created

and to see the output of the journal i’s here :

Unrelated: openvas and gvmd are constantly restarting due to missing files/libraries and produce a lot of noise.

The logs didn’t yield anything else than xorg is segfaulting, which was already clear. The backtrace is too short to tell anything from it. You could try reverting to the 470 legacy driver to check for a driver bug.

Did you read which libs were missing ?

and for that I didn’t succeed
I’ve noticed something : whatever i do is followed by a check of the current driver loaded
I use

inxi -G --display

and the result is always the same :

   Device-1: NVIDIA GM107GL [Quadro K2200] driver: nvidia v: 510.73.08
   Display: server: v: 1.20.11 driver: X: loaded: nvidia
      Unloaded: fbdev,modesetting,nouveau,vesa gpu: nvidia
   Message: No GL data found on this system.

looks like nvidia driver can’t be unloaded (or I dunno how to do it) and I can’t come back to nouveau as it was by default.

openvas: error while loading shared libraries: cannot open shared object file: No such file or directory
g_lstat(/usr/share/gvm/gsad) failed - No such file or directory

Here’s the backtrace of the Xserver

[  1527.586] (EE) 
[  1527.586] (EE) Backtrace:
[  1527.587] (EE) 0: /usr/lib/xorg/Xorg (OsLookupColor+0x135) [0x558ff1671845]
[  1527.587] (EE) 1: /lib/x86_64-linux-gnu/ (funlockfile+0x50) [0x7f49bb4f3140]
[  1527.587] (EE) 2: ? (?+0x0) [0x0]
[  1527.587] (EE) 
[  1527.587] (EE) Segmentation fault at address 0x0
[  1527.587] (EE) 

Unfortunately, too short to tell anything but graphics driver failed.

Thank you so much for trying to help me I tried some stuff to repaire openvas and Xserver but nothing worked I guess I now have to backup my files do a fresh installation and don’t mess up with drivers this time

Might be the best thing to do. I suspect something in the client libs/glvnd might be broken ( Otherwise, the nvidia driver would have been mentioned in the segfault backtrace.

1 Like

Yeah and that’s what I just did

That’s exactly what was the reason steam crashed before going in the dark “ returned code 2” or something like that !