Stuck while flashing the Nvidia Jetson Tx1

Hi all.

So giving a bit of backstory. I borrowed a Jetson Tx1 board for a project of mine and initially it was working well with Ubuntu (16.04). I got a prompt to update the Ubuntu Version. I had no idea about how updates work in Nvidia Jetson devices and I assumed, just like any other Ubuntu device it might update. But then I noticed it was kinda stuck at Started Journal Services and then when I went back to and fro in the docs and developer forum I understood I have no other option but flash the device. I’m using my laptop (Lenovo IdeaPad 330s) as the host to flash the device and i have Ubuntu 20.04 installed in my device. I did not have jetpack on the target machine (Tx1 board). I’m following the steps to flash and have tried to flash multiple times but it gets stuck at one place. When I referred the docs it gave me 2 options

  1. Reflash commands
  2. Flash command if device has not been flashed ever before.

Since I didn’t know if it were flashed or not I used the 2nd option i.e.

sudo ./ -r jetson-tx1 mmcblk0p1 but it kinda stopped after the progress bar turned 100 in the step of “Writing partition APP with system.img”. I thought this would take time but after one hour it was on the same place nd cursor wasn’t blinking.

Then I tried with the reflash command

i.e. sudo ./ -r -k APP jetson-tx1 mmcblk0p1

But that also stopped showing progress after completing 100% of writing like "Writing partition APP with <Location/of/Linux_for_Tegra/bootloader/system.img>

Now I’m stuck n kinda helpless.

Please guide me on this

hello vasudevsridhar29,

I’ve never seen this, the board should reboot after the flash process complete.
is this Jetson TX1 Developer Kit or you’re using customize board?

Hey JerryChang.
I am using the Jetson TX1 Developer Kit.

I actually found the solution from here: GitHub - mettadore/tegra-flash: Instructions and files to flash my TX2

This document worked and now my device is up and running
Thanks for replying.

hello vasudevsridhar29, okay, thanks for sharing.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.