Stuttering at 4k 60Hz

Hi,

I have a bit of a problem that I’m struggling to get to the bottom of, I have a GTX 980 which I’m using for a home cinema/gaming setup hooked up through a receiver and then into an LG OLED65B6V, before that I was using a Samsung UE55JS9000 which presented with the same problem. I’m running Debian on this set up with the 367.44 Nvidia drivers.

If I run my display at 1920x1080 @ 60Hz everything is fine, it’s all smooth and I don’t get any problems, however as soon as I switch to 3840x2160 @ 60Hz I get this problem. The only way I can describe it is that it isn’t smooth, actions seem juddery and even scrolling menus in Kodi seems to cause stuttering. When I say juddery I don’t mean like it is at 30Hz it just seems sort of irregular, frames seem to skip.

Oddly if I run it at 3840x2160 @ 30Hz it’s obviously lower FPS but it doesn’t skip.

It’s important to note this seems to be all the time, whether I’m playing a video or rendering 3D doesn’t seem to matter.

Now obviously this is hard for me to demonstrate via video but here are a couple of comparisons between 4k/1080p:

4K 60Hz
GLXGears -


Kodi -

1080p 60Hz
GLXGears -


Kodi -

I’ve tried taking the receiver out of the loop, that’s not the source of the problem. So I’m struggling where to look now!

Does anyone have any ideas?

Thanks,
Paul

What driver version are you using? If your monitor needs YUV 4:2:0 mode for 4k @ 60 Hz, then it has to go through the screen composition pipeline. There were some improvements in the 370.* driver series that should improve animation smoothness when the screen compositor is enabled.

Aaron,

Thank you so much, this has actually solved the problem! I thought I was going to go crazy I’ve been trying to sort this myself for ages.

Great stuff.