Substance Painter: error trying to import mesh from Onmiverse

Hello, I’ve correctly setup my Nucleus and exchange seems to work from Substance painter to Create, but not when I first load a mesh into Create and then want to import it into Substance painter.

In Create I have this message :

image

And in Substance Painter I have :

Not sure what’s happening ?

thanks,

Hans

Has anyone success import meshes from Create to Substance Painter ? is there another workaround to use Substance painter with Create ?

thanks

Hello @HansVanEven! I contacted the dev team for more help with this. I will post back when I have more information!

1 Like

Thanks Wendy, that would be great :)

Hi @HansVanEven. Sorry you are having issues but thanks for reporting this to us.

Would you mind sharing a screenshot of you stage view inside of Create?

What do you have selected in Create before you press “Import Mesh from Omniverse” inside of Painter?

1 Like

Hi Terry, sure here you go so two screenshots as you can see I have the guitar tuner selected in Create (this is a model I did in fusion 360 and exported to usd format) and then try to import mesh into Substance Painter, I also tried to simply select one mesh with the same issue. Thanks for your help!


Can you please share the usd file with us so we can take a closer look?

How was the model exported to usd format specifically?

Thank you.

1 Like

Hi Terry sure, but this also occurs on other file types and models not juste this one, so far I wasn’t able to import any mesh into SP from Create. I’ll send you the file by PM, this one was created in F360 exported to .step, imported to Keyshot and then exported to .usd I use this way of doing right now as this is the only way to maintain nice tessellation quality.

As you can see here I have the same issue trying to import an asset from Create (plant) in Substance Painter so I don’t think it’s related to the model. Nucleus works fine here, so maybe it’s related to the substance painter plugins itself ?

Importing the plant should be a different issue. I tried importing it myself and received a different error than what your mesh was giving. The plant can’t be imported because it’s locked on a server. It requires you to save it as a new usd before allowing you to open it.

As for you mesh I dragged and dropped your usd file into my user directory on Ominverse and tried importing it into Painter. It gave me an error telling me that it didn’t have UV coordinates. I opened the file in Maya using the Maya connector and gave it UVs. After that I was able to import it into Painter.

However, I still think there is a bug here. I’ll report back here the moment we have a solution. Sorry for the inconvenience.

1 Like

I was able to repro your issue on a different mesh. Just to be for certain that we are getting the same error, would it be possible for you to provide the full script error that you are seeing in Painter?

I’m looking for the last portion of your error message after World0/00000…

If I create a cube inside of Create and try to export to Painter I get this error in Painter and I think they might be similar.
image

This will be helpful to add to the bug. Thanks.

1 Like

Hi Terry,

Thanks for coming back to me. Indeed when I export from Fusion 360 there are no UV’s but for me the purpose is to use Substance painter for this and add UV’s there. I’ll try to add UV’s prior to adding the file to Create and see how it works.

Here’s the error message I get with the initial model I sent to you

[Script] qrc:/js/project.js:147: ProjectError: meshFile file:///C:/Users/Utilisateur/Documents/Adobe/Adobe Substance 3D Painter/export/0000029635E948A0:World0/0000029635E948A0:World0.fbx isn’t a valid url on an existing file

I tried to create a cube inside Create and have the same error coming up

[Script] qrc:/js/project.js:147: ProjectError: meshFile file:///C:/Users/Utilisateur/Documents/Adobe/Adobe Substance 3D Painter/export/00000296606E77F0:World1/00000296606E77F0:World1.fbx isn’t a valid url on an existing file

thanks

Some more info : I just applied UV coordinates to this model, baked them and exported to a new fbx model and tried again but still have the same error message.

I can import it to substance painter (with or without UV’s) using the usual substance painter import dialog without using Create, but I can’t import the mesh when I put the model in Create and connect to substance painter, the import mesh doesn’t work here.

Is your mesh a saved USD file somewhere on Omniverse before you are attempting to import into Painter?

That’s an interesting workflow that we don’t have support for yet unfortunately. I’m going to make this a topic of discussion with devs going forward to see if we can find a way to support the UV options on import from Create.

As for the world1.fbx isn’t a valid url on existing file error, my suspicion is that the file isn’t saved as a usd on Omniverse at the time of your attempt to import. The only time I’ve been able to reproduce this error message is when I bring something into Create that hasn’t been saved yet.

We’ll eventually get you squared away :D

1 Like

Thanks so much Terry for your time on this so indeed the file wasn’t saved in Create so it couldn’t be loaded in SP, now things seem to work much better and such a pleasure to be able to use Substance Painter, thumbs up !

1 Like

Fantastic! Glad to help. Feel free to reach out to me here or on Discord if you catch anymore snags in Create.

Cheers!

1 Like

Cheers :) Thanks for the great support also to Wendy !

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.