Successful Compile and Link Not Producing exe CUDA 4.0 with VS2008 - "build successful" but

Hello, I’m new to CUDA programming and I was hoping someone could help me. I hope this is the right place for this topic.

I am using Windows 7 64bit, MS Visual Studio 2008 Pro, and CUDA v4.0.

My application consists of a single VS project with several “.cu” source files and several “.cuh” header files. It accesses numerous external C++ libraries and a few CUDA libraries and headers. When I build the solution, the output window displays the expected




1>Project - 0 error(s), 0 warning(s)

========== Build: 1 succeeded, 0 failed, 0 up-to-date, 0 skipped ==========

message, but when I attempt to run the program I receive an error message stating that the .exe file could not be found. (I disabled the ‘embed manifest’ phase of the build after someone suggested it could be causing part of my original problem. If enabled, it produces a build error stating that the .exe file cannot be loaded - which is to be expected if no .exe is present.) I have manually searched the folders that the file would most likely have been erroneously saved into, and did not find it. I have since run an exhaustive set of system-wide automated searches and have not found the file. The only logical conclusion is that no executable is being produced. However, the compile and link processes report success at every stage, with no errors or warnings. I have tried removing and reinstalling all of the CUDA tools and programs and MS VS, in every reasonable permutation of install order, on the off chance that it might help. The behavior remains unchanged. Also, I have tried creating a much simpler shell of an application that did nothing of note, and it compiled, linked and produced a working .exe with the same build configuration. Double-checking my project’s build settings still resulted in the same behavior already noted. I feel like there must be something basic that I’m missing here, but so far I’ve been unable to find it. If anyone knows how this can happen, please let me know. Thanks in advance.

Bill E


It may be worth noting that I am attempting to build a 32bit application in my 64bit environment - I was originally trying to compile it as 64bit, but the build process produced numerous errors stating that various CUDA identifiers were undefined. I’m not sure why, but when I changed to a 32bit target and appropriately adjusted the library targets, it stopped producing those errors. I have not made extensive efforts to uncover the cause of this behavior as I still have not successfully compiled an executable. However, I’ve made some changes since then, and repeatedly attempted to reconfigure the build to 64bit, with the same results I saw before. My understanding is that compiling 32bit under 64bit should work, although the opposite may not. Please correct me if I am wrong.