Successful Cuda 7.5 install seems uninstall NVidia after reboot

I have been trying to install Cuda for GPU computing with Theano and Tensorflow and it’s been incredibly frustrating to say the least. I’ve tried many methods, all with a fresh install of Ubuntu 14.04, and my most successful attempts have been following these links: http://askubuntu.com/questions/672047/anyone-has-successfully-installed-cuda-7-5-on-ubuntu-14-04-3-lts-x86-64 http://spturtle.blogspot.com/2015/07/cuda70-and-theano-setup-in-ubuntu-linux.html

After going through these processes, I’ve been able to run the Cuda Samples successfully, but after reboot, theano does not work with the GPU, the command ‘nvcc -V’ tells me to install the cuda toolkit and nvidia commands no longer work. Upon inspection, cuda path files and important nvidia files are no longer in the folders they should be in.

As I said, I am running Ubuntu 14.04 and am relatively new to Linux, I am trying to install cuda 7.5, my computer is a Dell Precision T5500 with a 0CRH6C motherboard and my GPU is a Nvidia GeForce GTX 470. I have been able to successfully install the Nvidia drivers with the X Server application seeming to work well, but without Cuda, for a couple weeks. Finally, the command ‘lspci | grep -i nvidia’ always recognizes my gpu.

Any ideas? Thanks in advance.

follow the instructions in the linux install guide

if you’re not sure what that is, google “cuda linux install guide”

I’ve tried this method (and many others) and failed miserably. When I tried tried the instructions you referenced, the commmand ‘nvcc -V’ told me to install the cuda toolkit even though I had already done so and the suggested command defaults to cuda 5.5. Other methods I’ve seen online resulted in a black screen with a blinking cursor. The links I provided seemed to help fix that issue, but still some odd issues persist.

Any ideas why reboots seem to delete my nvidia drivers (from my admittedly novice perspective)?

have you made appropriate changes to your PATH and LD_LIBRARY_PATH variables?

after a reboot when you say the nvidia driver is “deleted”, what is the result of running:

nvidia-smi

?

If this results in a command not found or similar error, then I can only imagine there is a problem with the package manager install method that you used. You could try switching to a clean load of Ubuntu 14.04 and try the runfile installer method that is also documented in the linux install guide.