Sudden Logout problems? Create new user!

Regarding : Jetson TK1 / Ubuntu
This is rather a dirty workaround than a solution, but it works for me ;)

Problem: Out of nowhere: you’re logged out and of course all your programs are gone if you log in again. This keeps getting worse, until you reach the point where your loggin is immediately answered with a logout.

Solution: Create a new linux user via terminal, and make him superuser, then log on with that user. I’m not sure what even causes the loginlogout trouble, but for now, this works. I’ll keep you up to date on that issue.

Sounds very promising, thanks for sharing! Could this per chance be the issue I documented in my thread?

I have seen a sudden logout after longer runtime when there was no more free memory. Might adding a swap partition help ?

I am also having this same problem.

Do yall have better luck if you get rid of the Ubuntu Unity **** and switch to something else like Mate/Cinnamon/KDE/LXDE?

I installed the classic Gnome GUI because I do not like Unity that much.
#sudo apt-get install gnome-session-flashback
Now I can choose on Desktop login which GUI I want to use.

For those who have tried different desktops, how much disk space is used? I’d be curious what the “/” partition uses from “df -H”.

I also see sudden Ubuntu session logouts about twice a day !?
In which logs files should I look ?

  • I am using a classic gnome session not unity

issue: sudden Ubuntu session logout about two times a day
[updated] now one week uptime without a sudden Ubuntu session logout

Since I switched the CPU governor from ondemand to Performance
the sudden Ubuntu session logouts did not happen any more on my board for 72 hours.

Switch to performance governor from the Command line or use the Gnome panel CPU frequ. plugin:
sudo -i
echo performance > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor

My configuration:
Ubuntu 14.04 updated to latest packages
Gnome 2 style desktop (gnome-session-flashback is installed)

Drawback:
At least one CPU core always runs at full clock speed (2.32 GHz) which is not
a problem for the Jetson Tk1 but might be a problem for a mobile device
causing more battery consumption.

Best Regards,
Peter Bauer
http://bitkistl.blogspot.com

Hello Peter, the recent thread regarding the settings change for the CPU governor was updated with another workaround suggested by an engineer here at NVIDIA: https://devtalk.nvidia.com/default/topic/777077/embedded-systems/replace-unity-with-lubuntu/post/4319653/#4319653. Did you attempt that workaround as well and, if so, did it have any effect?

No I did not try this workaround - lets see what comes with next L4T release.