sudo apt-get install git cmake fail

Hi,
I follow the link (https://github.com/dusty-nv/jetson-inference/blob/master/docs/building-repo-2.md?source=post_page-----f5ad4758422d----------------------
) to install cmake (sudo apt-get install git cmake),
error messages shows as below:

正在讀取套件清單… 完成
正在重建相依關係
正在讀取狀態資料… 完成
git 已是最新版本 (1:2.17.1-1ubuntu0.4)。
有些套件無法安裝。這可能意謂著您的要求難以解決,或是若您使用的是
unstable 發行版,可能有些必要的套件尚未建立,或是被移出 Incoming 了。
以下的資訊或許有助於解決當前的情況:

下列的套件有未滿足的相依關係:
cmake : 相依關係: libjsoncpp1 (>= 1.7.4) 但它卻無法安裝
相依關係: librhash0 (>= 1.2.6) 但它卻無法安裝
相依關係: libuv1 (>= 1.4.2) 但它卻無法安裝
E: 無法修正問題,您保留 (hold) 了損毀的套件。

I saw one cmake related install topic in this forum to do sudo apt-get update, but still has the same error,

Can anybody tell me why or how to fix it on Jetsaon Nano, Thanks a lot.

I am not able to read the error, but if apt-get update and that apt-get install are failing, disable any alternate apt repositories you may have enabled, or if the situation doesn’t resolve itself, re-flash the SD card and try this again before installing other packages.

If this was with a fresh SD card you just flashed, then unattended-upgrades may be running (I am not sure of the error), so give it some time until unattended-upgrades completes.

Thanks your reply, I’m sot sure what you mean.
But I did below things then it works now.

  1. I used another 64G SD card to download image again.
  2. I chose default “English” environment not Traditional Chinese I chose last time.
  3. I did the same thing sudo apt-get install cmake, error messages occurs still.
  4. Then I sudo apt-get update. done (in my last 32G SD, this update command doesn’t fully success)
  5. sudo apt-get install cmake.
  6. success