Support for Fermi 5XX


I have a few GTX 560 Ti that I plan to use in OpenCL development. However, from what I read, there is very little support for these new cards.

I tried OpenCL 1.1, but some of the examples make my computer reboot. Is this normal? I also tried the public OpenCL 1.0 version, but it seems incompatible with my drivers’ version. I get an API mismatch error.

I would like to know if there are other alternatives. Should I try the Stream SDK from AMD?


I also recently got a 560Ti and have had some driver issues. Both the motherboard and operating system are factors. In my case I have an AMD chipset motherboard and this configuration is extremely unstable under linux. The nVidia drivers clash with the AMD sata drivers and cause hard drive corruption when using X windows. Anyway, I could not get OpenCL 1.1 working because it will ONLY work with the supplied driver version which does not support the 560Ti. However, I did get all the SDK examples working under both linux (using a beta driver, and X windows disabled) and Windows Vista. As far as the ATI SDK, the OpenCL examples should work, but most likely will not if you have a driver issue. The drivers in the ATI SDK will not do anything for your nVidia card. I hope this helps.

Thanks for the help.

I am using an Intel motherboard (Asus P7P55-m), but I will check the drivers. I am using Ubuntu 10.10 64bit, OpenCL 1.1 and the latest beta driver for 560Ti: 270.40.26. Like you, I can run the examples if the X server is off, but some of them crash the computer. MatrixMul and Vector add for example, don’t work. I will look into this to try to understand the problem with these examples.

I sort of gave up on OpenCL 1.1. It works sometimes… I was trying to get OpenCL 1.0 to work so I can have a more reliable setup. I saw on other threads that some people are running it fine, but I have this API mismatch error:

$ ./oclMatrixMul 

./oclMatrixMul Starting...

Error: API mismatch: the NVIDIA kernel module has version 270.41.06,

but this NVIDIA driver component has version 185.18.08.  Please make

sure that the kernel module and all NVIDIA driver components

have the same version.

Error: Failed to create OpenCL context!

!!! Error # -1 at line 97 , in file oclMatrixMul.cpp !!!



Does anyone know what am I doing wrong? I am using Ubuntu 10.10 with NVIDIA-Linux-x86_64-270.41.06, cudatoolkit_4.0.13_linux_64_ubuntu10.10. I downloaded OpenCL 1.0 from my developer zone. It is dated 6/12/2009

Yes, downloading and installing an obsolete OpenCL 1.0 distribution over the top of an existing, up-to-date OpenCL 1.0 distribution. If you have installed a current driver and matching current toolkit, you already have OpenCL. Nothing else is required.

Oh… You’re right. I’m sorry, it was a silly question… The OpenCL page isn’t very informative about 1.0 and I thought that I needed the SDK, just like I need for AMD products. Anyway, it’s working now. Thanks a lot!