Support for Ouster Lidar OS1-64 Gen2

Please provide the following info:
Software Version
DRIVE OS Linux 5.2.0
DRIVE OS Linux 5.2.0 and DriveWorks 3.5
NVIDIA DRIVE™ Software 10.0 (Linux)
NVIDIA DRIVE™ Software 9.0 (Linux)
other DRIVE OS version

Target Operating System

Hardware Platform
NVIDIA DRIVE™ AGX Xavier DevKit (E3550)
NVIDIA DRIVE™ AGX Pegasus DevKit (E3550)

SDK Manager Version

Host Machine Version
native Ubuntu 18.04

Got some issue on displaying the lidar point cloud captured from Ouster lidar OS1-64 Gen2 with 45Deg vertical field of view. Not sure if there is a support issue on this sensor. See the image below. Thank you!

Dear @baoxin.chen,
Is it from live sensor or replaying the recorded data? Could you share the steps/data/logs to reproduce the issue.

Hi Siva,

The image above is from the recorded data. The same problem also occurs on live sensor data. No matter how I change the horizontal resolution and frequency, the problem could not be solved. I will capture a small batch of data and share it here later today.
FIY, the OS1-64 gen 1 with 33.2Deg FOV works fine on Pegasus.

Hi Siva,

We had captured two small data sequences to compare the problem of the Gen2 lidar. You could download them from this link.
Both lidars were set as ip=, hres=1024, scan-frequency=10. Below is the command we ran to visualize the real-time data.
./sample_lidar_replay --protocol=lidar.socket --params=device=OUSTER_OS1,ip=,dip=,port=7502,hres=1024,scan-frequency=10 --show-intensity=true
This is the command we use to visualize the replay data:
./install/bin/sample_lidar_replay --protocol=lidar.virtual --params=file=Path/lidar_ouster.bin --show-intensity=true

Hi @baoxin.chen,

Can gen 2 be configured as 33.2 degree? If yes, is this issue also reproducible on it?
Could you check this with Ouster to see if the issue is expected on your conditions (45 degree, resolution, speed, distance)?

Hi Vick,
OS1-64 Gen2 can not be configured as 33.2 Deg.
According to the DRIVE Ecosystem Hardware and Software Components, 45 Deg should be supported.
I tested both Gen1 and Gen2 sensors with the same configuration (hres:1024, frequency: 10) on a Linux system using Ouster’s software, both are fine.
Ouster support team also said that they haven’t change the data format.

These two images were rendered using the “sample_lidar_raplay” tool. The first one is from Gen1, the second one is from Gen2. They are captured at the same scene.

Gen 1 and Gen 2 are different lidars so they will have difference performances.
Please check this with Ouster. They can give you better explanation on this. Thanks!

Hi Vick,

After talking to Ouster, they said since the vertical angle is different, it will require a different config/calibration file. Do you know if we could make these changes on Pegasus?

Could you ask them to provide more information about the configuration/calibration file of Gen 2? Have they worked on it with nvidia? Are these files already part of DRIVE OS 5.2.0? What’s the file names? Thanks!

Hi Vicki,

Thank you! OS1-64 Gen2 is working on Drive OS 5.2.0

1 Like

Hi Vick,
Re-open this problem since the recording tool (/usr/local/driveworks/tools/capture/recorder) has not fixed for OS1-64 Gen2. I saw the same problem on the lidar data binary file. But the sample_lidar_reply is fixed when running on the live sensor.
Could you help me if it is possible to fix the recorder BUG by myself?

Please create another topic linked to this topic for this. Thanks.

Please share the details of how the issue on sample_lidar_replay with Ouster OS1-64 Gen 2 was solved?

Hi Vick,

Thanks for your reply!
After the inspection on DriveWorks 3.5, the live Ouster OS1-64 Gen2 lidar is working, but the recorded binary file can not be played correctly using “sample_lidar_replay” with “–protocol=lidar.virtual”. I am going to create a new post to describe the BUG.

1 Like

share the topic your creating here. Thanks.

Please help to share how you made it work so other developers can refer to this topic. Thanks.

Hi Vick,

I didn’t do anything other than installed DW3.5. But, I discovered a new BUG on the “virtual lidar” when the binary file is recorded using OS1-64 gen2. Please refer to the other post I created.