Suspend corrupts window manager (?) after upgrade to 378.09

There was a regression in 378.09 that will be fixed in the next release.

Workaround is to run “compiz --replace”. This will restart compiz (you won’t lose all of your windows). This is under 14.04, btw.

I also have the same kind of problems under Fedora 25 running GNOME. But I also tested on Ubuntu 16.10 and I have the same problems that you guys have, so I think that the problems are indeed the same or at least related.

On Fedora I’m getting graphical corruption/artifacts after resume. It starts with minor glitches but it rapidly starts to get worse until the system just hangs. I can’t get into any tty (e.g., CRTL + ALT + F3).

I was able to alleviate the issue by disable “Allow flipping” on NVIDIA Settings. However, it doesn’t fix everything. For instance, a few moments after resuming the cursor disappears. I can actually make it happen right away if I start playing a video (e.g. on YouTube). If I move the mouse out of the video and into it, the cursor just vanishes. Also, the tty continues to be inaccessible. If I change my screen configuration (disable one of my screens) the system also hangs.

So, in general, a system that works fine right after boot gets completely borked after sleeping and resuming. Can please NVIDIA fix these issues?

Also, is there any workaround that you can recommend? I’m not running Ubuntu with Unity, so I can’t do “compiz --replace”. I actually tried “gnome-shell --replace” but I just get a black screen :(.

My laptop is an ASUS ROG GL502VM with a GTX 1060. Also, unfortunately, since this laptop has G-SYNC technology I’m unable to use the Intel GPU instead of the NVIDIA GPU. Had I known beforehand that G-SYNC would prevent me from using the Intel GPU, which usually works much better under Linux, I would have probably tried to find a model without G-SYNC.

petersaints

I have a MSI GS63VR with GTX 1060. It supports switching to Intel, but with Intel my HDMI or DisplayPort do not work. Other than that, Intel is really stable. Only reason I am using Nvidia mode to connect my laptop to my monitor.

@umarov And you also have resume problems on your laptop, right?

yeah, everything gets corrupted after resume. I lose the wallpaper. In addition to that, when I unplug the DisplayPort, everything crashes. It logs me out, when I log back in, only system applications are left open.

It seems that we are all in the same boat. GTX 1060 (and perhaps all other Pascal cards) just won’t suspend and resume the way they should on Linux. :( I really hope that they release a new version that fixes it soon. It’s so annoying not being able to use the suspend function. I mean, at least with an SSD, it doesn’t take too long to boot, but still… it’s annoying as hell!

I was able to find a nice work around to my problem. I just had to enable “Launch CSM” on my BIOS. Perhaps others can try it out as well.

It doesn’t make much sense. But I’d guess that the NVIDIA driver relies on something that is only exposed when I run my system in CSM mode. It’s not perfect, but it’s better than having to reboot my PC all the time.

Recent update introduced this problem to 375 drivers as well. Now I have no choice but to run unity --replace after every wake.

this workarround fix for me!

@experimancer Thank you for sharing.

Given that simply killing compiz process fixes the bad border problem, I have tested a solution that works on my Ubuntu 16.04 system every time after the system wakes. 2 steps solution. Hope it can help others.

Step 1:

I created a script called “fixbadborders” in the directory /lib/systemd/system-sleep.
It contained the following:
#!/bin/sh

This file (or a link to it) must be in the folder /lib/systemd/system-sleep/

Purpose: Kill compiz after system wakes up from sleep.

This will fix bad window borders caused by Nvidia driver 375.39.

kill $(ps -C compiz -o pid=)

Step 2:

Allowed the script to have executable permission with:
sudo chmod +x fixbadborders

Thanks for sharing, worked for me as well on Ubuntu 16.04

Seems that I also lost all sound with recent 375.39 update…

Sarka, try remove your pulse hidden folder to reset your pulse audio server.

Go to your home, and push control+h and reveal yours hidden folders, and go to .config and delete your pulse folder, and reboot your system. See the sound came back.

I just posted this in another thread:

[url]https://devtalk.nvidia.com/default/topic/994287/linux/corrupted-screen-after-resume-now-with-375-39-and-378-13-/post/5112047/#5112047[/url]

platao, I found other solution for sound already:

https://help.ubuntu.com/community/DigitalAC-3Pulseaudio

Not through HDMI, but that’s fine for me :) Thanks anyway!

When is this going to be fixed?

P.S. I’ll never buy an Nvidia product again.

Fodix, it should be fixed in the next release.

aplattner,

When is going to be released a new linux driver??? and why the linux version driver is a little older than the windows version?

I also started getting this on 375.39 two days ago. Here’s an image: https://img42.com/XTzu6 (for the next 30 mins). Very colorful around the edges. Similar to other posters.
This is on Ubuntu 16.04 and everything up to date. Nvidia Geforce 610M 2gb

Rolling back to 340.102 gives a similar result after suspending, but gives a white boarder instead. https://unsee.cc/pusenizo/ (this is a better service - one day before it’s gone!)

Yes. This is a problem for me. My driver 378th
Nvidia GForce 740m.
Fortunately, I have also integrated vga.
But I am very interested in the solution to my problem.https://goo.gl/JMyrG6

[url]https://goo.gl/JMyrG6[/url]