Symbol lookup error with nvv4l2decoder in cv::VideoCapture()::release()

Hi,there

I have the following pipeline used in openCV on Jetson Nano

v4l2src device=/dev/video0 io-mode=2 extra-controls=s,exposure_auto=1,contrast=0,exposure_absolute=1 ! nvv4l2decoder mjpeg=1 ! nvvidconv ! video/x-raw, format=RGBA ! videoconvert ! video/x-raw,format=BGR !  appsink drop=1

It works well but when the program is finish and call videoCapture.release(), I got the folowing error

./build/bin/gstreamer_demo: symbol lookup error: /usr/lib/aarch64-linux-gnu/tegra/libnvmmlite_video.so: undefined symbol: NvMMLiteBlockSendEOS

I checked the libnvmmlite_video.so is exist, and my nv_tegra_release content is

# R32 (release), REVISION: 4.4, GCID: 23942405, BOARD: t210ref, EABI: aarch64, DATE: Fri Oct 16 19:44:43 UTC 2020

CUDA version is 10.2

Any advice?

Thanks

Hi,
Are you able to upgrade to later version such as Jetpack 4.6 or 4.6.1 and try again?

Thanks for your replay.
I have upgraded to Jetpack4.6.1, here is the new nv_tegra_release content:


# R32 (release), REVISION: 7.1, GCID: 29818004, BOARD: t210ref, EABI: aarch64, DATE: Sat Feb 19 17:05:08 UTC 2022

But the error is same

Hi,
We have tried this string and don’t see any issue:
Set camera decoder in OpenCV on Jetson Nano - #8 by DaneLLL

Please give it a try.

I’ve tried the following string but the error still occurred when VideoCapture release was called

 v4l2src device=/dev/video0 io-mode=2 extra-controls=s,exposure_auto=1,contrast=0,exposure_absolute=1 ! jpegparse ! nvv4l2decoder mjpeg=1 ! nvvidconv ! video/x-raw, format=RGBA ! videoconvert ! video/x-raw,format=BGR ! appsink

Any other solutions?

Should I re-setup my device? Install the latest jp461 sd-card image?

Hi,
Please clean cache and check if it helps:

$ rm .cache/gstreamer-1.0/registry.aarch64.bin

If the issue is still present, may try either USB camera and see if it works. Generally USB cameras support MJPEG and can be a reference camera.

1 Like

The error still occurred.

Is this related with the OpenCV? I used the version 4.4.0.

I’ll try OpenCV 4.5.x and update this post if have some result

Thanks for your time

Have you tried with OpenCV 4.5.x?
Is this still an issue to support?

Thanks

I’ve tried OpenCV 4.5.1, but it still not worked, same error.

Hi,
We suggest you re-install the system image and SDK components. By default there is a 4.1.1 package.