System Architecture Error, NVIDIA specific first-boot script fails

I came across an error with the architecture of my system. When I tried to run JetPack-LT4-2.1-linux-x64.run, I got a popup that said: “JetPack must be run on x86_64 HOST platform. Detected platform”

When I type the command arch into the terminal, I get armv7l. In order to download the JetPack, I need x86_64. I did some research and didn’t come across any information about how to switch from 32-bit to 64-bit so I decided to start over, following the instructions of this link: http://charlab.github.io/jetson/2014/10/28/how-to-reinstall-original-file-system-on-jetson-tk1/.

I got an error at step 2 but I tried 3 and 4 anyways:
(2) Get Jetson TK1 board support package aka BSP (called Tegra124LinuxR19.2.0_armhf.tbz2)
wget https://developer.nvidia.com/sites/default/files/akamai/mobile/files/L4T/Tegra124_Linux_R19.2.0_armhf.tbz2

(3) Get sample file system file (called TegraLinuxSample-Root-FilesystemR19.2.0armhf.tbz2)
wget https://developer.nvidia.com/sites/default/files/akamai/mobile/files/L4T/Tegra_Linux_Sample-Root-Filesystem_R19.2.0_armhf.tbz2

(4) Extract the BSP tarball
sudo tar xpf Tegra124_Linux_R19.2.0_armhf.tbz2

This didn’t solve the issue and now, when I startup the Jetson, the NVIDIA specific first-boot script fails.

How do I restart my system and set it up for 64 bit processing? Thank you!

The flash program and related are intended to run from an x86_64 Linux desktop host, versus the Jetson itself (the host runs the programming to modify Jetson over the micro-B USB port, possibly extra packages may be installed over ssh). Jetson TK1 as a target is ARMv7, desktop host as executor is x86_64.

When the original Jetson arrives, the home directory contains “NVIDIA-INSTALLER” subdirectory. The subdirectory contents would be an entire set of Jetson flash software, but the “installer.sh” is a subset of an install that only unpacks nVidia-specific files without flashing (if manually flashing from a desktop host using the driver package plus sample rootfs this is the same as the “apply_binaries.sh” step). Basically a fresh Jetson without any installer steps arrives as purely Ubuntu 14.04LTS and no hardware acceleration…either the “NVIDIA-INSTALLER” directory or desktop-based host running apply_binaries.sh and flash result in the same hardware accelerated addition of files (without apply_binaries.sh a full flash would be pure Ubuntu 14.04LTS minus nVidia-specific files).