System clock is always reset to Feb 1

I have orin nano and system clock is always reset to 1/Feb/2024 on boot.
How can I set it to have correct time on system boot?

Plug-in the Ethernet cable and enable this in Ubuntu:
https://help.ubuntu.com/stable/ubuntu-help/clock-set.html.en

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.