System does not boot after JetPack upgrade from 4.4 to 4.4.1

So this issue is reproduced when you configuire jetson io and then upgrade.

Could you tell us what pin did you configure in jetson-io?

I set these pins: pwm0 (32), i2c (27, 28).

I think the problem is that jetson-io creates custom dtb (tegra210-p3448-0000-p3449-0000-b00-user-custom.dtb) that is not compatible with the new version of L4T. Probably the specific pin settings don’t matter.

LABEL JetsonIO
	MENU LABEL Custom 40-pin Header Config
	LINUX /boot/Image
	FDT /boot/tegra210-p3448-0000-p3449-0000-b00-user-custom.dtb
	INITRD /boot/initrd

Also, I had this problem with some previous updates of L4T. Some updates were successful, some were not. Earlier I had to create a new SD image with the current version of L4T and restore my project again.

Let me put the problematic log from your text file here.

18:17:46:348] [ 0.000000] Preemptible hierarchical RCU implementation.␍␊
[18:17:46:348] [ 0.000000] ⇥ Build-time adjustment of leaf fanout to 64.␍␊
[18:17:46:376] [ 0.000000] ⇥ RCU restricting CPUs from NR_CPUS=64 to nr_cpu_ids=4.␍␊
[18:17:46:376] [ 0.000000] RCU: Adjusting geometry for rcu_fanout_leaf=64, nr_cpu_ids=4␍␊
[18:17:46:376] [ 0.000000] NR_IRQS:64 nr_irqs:64 0␍␊
[18:17:46:376] [ 0.000000] /interrupt-controller@60004000: 192 interrupts forwarded to /interrupt-controller␍␊
[18:17:46:402] [ 0.000000] t210 clock and reset probe␍␊
[18:17:46:402] [ 0.000000] tegra-pmc: get_secure_pmc_setting: done secure_pmc=1␍␊
[18:17:46:424] [ 0.000000] clk_cbus_recalc_rate: no gbus parent␍␊
[18:17:46:424] [ 0.000000] clk_cbus_recalc_rate: no gbus parent␍␊
[18:17:46:424] [ 0.000000] clk_cbus_recalc_rate: no gbus parent␍␊
[18:17:46:448] [ 0.000000] clk_cbus_recalc_rate: no gbus parent␍␊
[18:17:46:448] [ 0.000000] clk_cbus_recalc_rate: no gbus parent␍␊
[18:17:46:448] [ 0.000000] arm_arch_timer: Architected cp15 timer(s) running at 19.20MHz (phys).␍␊
[18:17:46:448] [ 0.000000] clocksource: arch_sys_counter: mask: 0xffffffffffffff max_cycles: 0x46d987e47, max_idle_ns: 440795202767 ns␍␊
[18:17:46:476] [ 0.000006] sched_clock: 56 bits at 19MHz, resolution 52ns, wraps every 4398046511078ns␍␊
[18:17:46:476] [ 0.010048] Console: colour dummy device 80x25␍␊
[18:17:46:476] [ 0.014705] console [tty0] enabled␍␊
[18:17:46:499] [ 0.018221] bootconsole [uart8250] disabled␍␊

Hi lich.mk,

Using default JP-4.4 GA (r32.4.3) image, I don’t see the i2c (27,28) pins, where are you set those two pins?

Yes, I was wrong. I configured only pin 32.

Hi lich.mk,

I think we find the cause of this issue.

  1. OTA does not know you have a customized dtb by jetson-IO so it just keeps it there with no change.
  2. jp4.4 DTB cannot be used on jp4.4.1. There would be some incompatible issue.

Thus, with (1) +(2), it caused the system not able to boot up. You can only re-generate dtb after you upgrade to jp4.4.1.