System halted when flash TX2 using SDK manager

I use sdk manager to install jetpack4.3 on jetson TX2. But when flash Linux L4t or install sdk,TX2’s will system helped .After that I can’t use button to reset my tx2。please help me

The “recovery mode” button does not actually do anything other than to put the Jetson in a mode capable of being flashed. If a flash took place and failed, then normal boot would fail until flashing again. If the flash worked, but you lack video output, then this might be a video issue and not a failed flash. If a VM is used, then flash is expected to fail, so we’d need to know if a VM was used, and we’ll need to know specific symptoms.

Also, is the monitor HDMI? VGA adapters will fail.

The monitor is HDMI and I use VM.When I flash L4T ,screen show nothing.When tx2 crash,I even can’t reset it.The only thing I can do is pulling out power for about 10 min,then I can let Tx2 in recovery mode. Now,I have flash L4t in tx2 by using command line. But still meet Tx2 crashing when I install Sdk component by SDK manager. Can I install these components on TX2 and not use host?

VMs tend to fail. During flash USB disconnects and reconnects several times. If the VM does not always get control of the reconnected USB (and most often the VM does not keep the connection), then flash will have truncated and the flash will be incomplete. VMs are not officially supported, but this does not mean it can’t be made to work with extra effort.

Unfortunately, I do not use VMs and every VM has its own methods of fixing the issue so the recovery mode Jetson is always passed through.

If you think the VM is working, then you can flash on command line and log. You have already tried to flash with JetPack, and so the installed files will already be present and all you need to do is run a command. Normally this would be:

sudo ./ jetson-tx2 mmcblk0p1

If you instead want to save a log of this:

sudo ./ jetson-tx2 mmcblk0p1 2>&1 | gawk '{gsub("[0-9][0-9]+[/][0-9[0-9]+ bytes sent..",".");print}' | tee log.txt

Then attach the “log.txt” in the forum.

If there is any way you can dual boot to Ubuntu 18.04 your life will be much easier versus using a VM.

Please read this wiki page and provide logs.