System hangs with 340.76 under Fedora 21

Hi all,

I have been experiencing consistent hangs of my system with driver 340.76 under Fedora 21 (x86_64) - usually only a few mins after starting X.

I’ve provided more details (including kernel stack/call trace from journal) and output of nvidia-bug-report.sh at https://bugzilla.rpmfusion.org/show_bug.cgi?id=3602. Any help would be appreciated! Please let me know if I can provide any other useful info.

Regards,

Russ

Switched back to the 304 version of the driver, plus the fix from https://bugzilla.redhat.com/show_bug.cgi?id=1195074, and it’s now working for me. This is with a GeForce 8200 which is listed as supported by the version 340 driver.

Try with the “flip” option disabled. That used to cause complete system hangs, when enabled, with older video card models.

Sorry brebs I didn’t see your reply; thanks for the tip. Any pointers on how to do this?

I’m back at this thread because of a problem on Fedora 23 (http://forums.fedoraforum.org/showthread.php?t=307767) which will hopefully be solved by going back to the 340xx driver - but I am hoping I don’t just bounce back into this bug again!

So the 340xx driver still has the same issue for me on F23. Disabling “flip” didn’t cure it, but for anyone’s future reference, I added…

Option "NoFlip" "True"

…to /etc/X11/xorg.conf, inside the block…

Section "Device"
   [...]
EndSection

You can use…

nvidia-xsettings ... --no-flip

…to do the same but it adds a whole load of apparently unnecessary cruft to the file.