System Requirement Query for VRWorks Audio

Hi

Im running a Quadro P3000.

The VRWorks Audio 2.0.4 readme suggest that GeForce 1070+ (or higher) is required.
Does this mean my card is definitely incompatible?

Also Im running Visual Studio 2017 Professional, but the system requirements suggest 2013/2015 is needed. Does this mean 2017 is not supported or may not work?

Please advise.