System throttled due to over-current?

I can also confirm this… i was running Hello AI World (jetson-inference) as per instructed in the github… first time noticed this message/error when for just the sake of trying something else changed --network=pednet in pedestrians.mp4 object detection

All 15W 2/4/6 core modes (only) give this message…

Image installation + all the latest updates done… HW jetson xavier nx dev kit

I have the same issues: ‘system throttled due to overcurrent’ when using DeepStream-test3-app on Jetson Xavier NX (JetPack 4.5).

I have the same issues: ‘system throttled due to overcurrent’,JetPack 4.4.1, we never got such a message.I’m not sure if it can be changed to 19v 5A

hi all,

we’re able to reproduce the system throttled due to overcurrent issue with the reference platform.
we’re having investigation internally, will update the results after we come out conclusions.


I also meet the problem, I run two model about pose estimation and yolov4-tiny at the same moment.

I used 15W 6 core mode, then it will appear the mistake.

Hello All,

I also get the same message but let me describe my context. I own the Jetson Nano. I am doing a show and tell by using a pre-trained model for image recognition (Works great with no Throttle message), I trained a Model on my Nano (It took an hour to complete but with success and no Throttle message), I used the Transfer Learning Technique to train a new model (Again no issues - no messages). This was using the NVidia Docker ML image 4.4.1. This little machine is powerful .This excitement convinced us to purchase the Xavier NX. Installed the newer NVidia Docker image 4.5.1 - Using our same models and Notebook code, On the pre-trained model we get the Throttle message, on the Training our own model we do not get the message but model accuracy was cut from 92% to 54%, on the Transfer learning model, we do not get a message the model accuracy is cut from 96% to 52%. We are running the NX on 15W 6Core. We finished faster but the accuracy is horrible compared to the 90% plus found on the Nano. We are now trying determine what may be happening here. Thoughts? And Thanks for any input!

1 Like

hello marvinbr,

let’s using this thread for tracking system throttled error messages.
please initial your follow-up question in the new discussion thread for better supports.

Same problem running the trt_pose example notebooks on a brand new Xavier NX dev kit with provided DC barrel adapter in any of the 15W modes.
Is there a workaround other than using 10W modes?

1 Like

same issue, I thought it has influence on the performance.

what about using 4.4 on Xavier NX?

Hello Jerry - No problem. I thought the Throttle issue could be affecting my decrease in model accuracy. Thanks.

Great question. We have not completed this test due to fact that the Docker container for 4.4 crashed on start. It said we had already installed a newer version 4.5.1 which was correct. We plan to flash a new drive for 4.4.

I’ve tried flash back to 4.4 then I got a performance boost and no more meaningless warnings.

I use Xavier NX for ZED 2 stereo camera. With same config, I got 30-35 FPS on 4.5 and 50-58 FPS on 4.4. Funny

1 Like

Interesting - we using the PI High Quality Camera using the CIS interface - On 4.4 we were getting about 12 FPS. When we got the NX and installed 4.5.1 it throttles between 25 and 50 FPS but never settles down like the Nano. Our next step is move back to 4.4 on the NX and plots these numbers.

Same here, it seems that it impacts performance

I have to admit… i have reservations about Xavier NX performance… Nvidia is on the top of this issue ? Jetpack 4.4 vs 4.5.1

HW should provide maximum performance for us clients ?

hi all,

we’re still investigate this issue internally, thanks

Can you give any updates how Nvidia is correcting performance issues ?

I know internal issues cant be said upfront but i guess we customers are eager to learn any positive corrective changes info we might get

Late to the party, however I’m getting the same throttling issue with the Xavier NX dev. kit running Jetpack 4.5 and the standard 19V 2.73A power brick. I saw this first while using the Stereolabs ZED SDK tools (ZED_Depth_Viewer & ZEDfu) while testing with a ZED Mini. I also didn’t see this issue with previous Jetpack versions.
Thanks for looking into this Nvidia, hopefully the internal investigations are going well.