System throttling due to over-current error with deepstream

Hi,

I have tried to run some deepstream scripts using our custom model which is a .engine model file. I am currently running three instances of deepstream_test1_rtsp_in_rtsp_out.py code. When I run a fourth instance, it just gets killed. What I am trying to understand is, the CPU cores and even the GPU RAM is not even close to running or getting filled up, so how can a stress test be done?


I am running on Orin NX with 8GB on Jetpack 5.1.1 with Deepstream 6.3.

So the goal is to stress the CPU/GPU or run 4 instances of deepstream_test1_rtsp_in_rtsp_out.py?
Please share the full log of this issue, thanks.

Apologies regarding my wording of the issue, but it’s to mostly run 4 instances of the deepstream_test1_rtsp_in_rtsp_out.py basically mimicking 4 camera inputs. So far, I have tried to run 4 instances on 20W mode, it seems to work but the RAM gets filled up instantly. Is there a way to squeeze in at least 5 instances or should I upgrade to a higher RAM? I assume the script is optimized for running on Jetson devices so I was hoping to run a few more instances.

I am also using a YOLOv5 small model trained on 640x640 image size. Additionally, Jetson Power GUI does not work on the machine, it just pops out and then goes off.

can you execute “sudo tegrastats” in a console when the deepstream programs running? You can see the CPU/GPU usage and overall power consumption.

In fact you can also use 4 RTSP input in one pipeline, which can save much resource in your case.

This is the stats so far:

Regarding 4 RTSP input in one pipeline, is there any script made by nvidia on this case?

deepstream_test1_rtsp_in_rtsp_out.py can also support multiple inputs. Jut like

python3 deepstream_test1_rtsp_in_rtsp_out.py  -i rtsp://xxxx rtsp://xxx rtsp://xxx rtsp://xxx rtsp://xxx 

Please read the code of the example first

The over power consumtion and temperature are both OK, I don’t understand why it trigger system throttle here, you may file a new topic in Orin NX forum to get support.
The GPU usage is high which is related with the Deepstream you are running. Currently you can try above proposal and check if there is still system throttle in the system.

Thank you for the reply. That run command definitely works with multiple RTSP streams as shown in the docs as well. However, there is definitely a long boot up time which is to be expected.

@yingliu Regarding the throttling, it seems to have gone now but if I have any further issues, I will definitely put up another post regarding the same in the Orin NX section.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.