Systemd-analyze does not work

Please provide the following info (check/uncheck the boxes after creating this topic):
Software Version
DRIVE OS Linux 5.2.6
DRIVE OS Linux 5.2.6 and DriveWorks 4.0
DRIVE OS Linux 5.2.0
DRIVE OS Linux 5.2.0 and DriveWorks 3.5
NVIDIA DRIVE™ Software 10.0 (Linux)
NVIDIA DRIVE™ Software 9.0 (Linux)
other DRIVE OS version
other

Target Operating System
Linux
QNX
other

Hardware Platform
NVIDIA DRIVE™ AGX Xavier DevKit (E3550)
NVIDIA DRIVE™ AGX Pegasus DevKit (E3550)
other

SDK Manager Version
1.8.0.10363
other

Host Machine Version
native Ubuntu 18.04
other


To check the services, I tried to execute systemd-analyze command, but it shows the message; ‘Bootup is not yet finished. Please try again later’.

I executed systemctl list-jobs and found there are two waiting services.

$ systemctl list-jobs
JOB UNIT                                   TYPE STATE
420 dev-loop0.device                       nop  waiting
421 sys-devices-virtual-block-loop0.device nop  waiting

However, I cannot stop those services and systemd-analyze still doesn’t work.
Of course, I tried reboot the system for several times, nothing improved.

How can I resolve this situation?

Do you observe this on a freshly flashed system? What’s the complete output of systemd-analyze?

No, user services are implemented on the system.
Unfortunately I cannot get the complete output of systemd-analyze as it does not work.
Also, the journal log was broken (journalctl --list-boot returns only one boot started at yester year).
Actually, just after I wrote the post, systemd-analyze worked correctly, but after about 10 times of reboot, AGX returned into the original status.
BTW, can I disable dev-loop0.device and sys-devices-virtual-block-loop0.device if they do not affect the system?

It was recovered.

  • systemctl enable fake-hwclock
  • systemctl start fake-hwclock
  • restart the system
  • systemctl list-jobs still shows dev-loop0.service and sys-devices-virtual-block-loop0.device
  • systemctl disable fake-hwclock
  • restart the system again
  • then, systemctl list-jobs shows “No jobs running.”
  • systemd-analyze works correctly.

So, which output of systemd-analyze do I put on here?

I don’t see the issue on my DRIVE OS 5.2.0 system. Below is for your reference.

nvidia@tegra-ubuntu:~$ systemd-analyze
Startup finished in 6.899s (kernel) + 1min 30.560s (userspace) = 1min 37.460s
graphical.target reached after 18.664s in userspace
nvidia@tegra-ubuntu:~$ systemctl list-jobs
No jobs running.

Thanks,

The result on my environment;

nvidia@XavierA: ~$ systemd-analyze
Startup finished in 5.385s (kernel) + 1min 30.715s (userspace) = 1min 36.100s
graphical.target reached after 20.665s in userspace

The issue isn’t seen on my clean DRIVE OS 5.2.0 system and your systemd-analyze output shows “Startup finished” so I presume you already solved the problems on your side. Thanks.

1 Like

One more additional quesiton.
In my AGX environment, AGX is connected to the internet.
Here is the result of systemd-analyze blame(excerpt);

         10.256s gdm.service
          9.362s nv_rtc_sync.service
          8.242s systemd-udev-trigger.service
          8.068s dev-vblkdev0p1.device
          3.550s logcontrol.service
          3.278s nv_board_init.service
          2.697s systemd-modules-load.service
          2.123s nv_ptp_master.service
          1.112s snapd.service

Could you please show the same one on your system?
I’m afraid nv_rtc_sync needs too long time.

Please help create a new topic for this. Thanks.

1 Like