Taking a lot of time while running a lid driven cavity simulation

Hello all,
I am new to SimNet and have installed it using docker on the ubuntu machine. When I tried to run the first tutorial, lid-driven cavity, it is taking a huge time to run, around more than 10 hrs.
When I installed SimNet, it gave me the warning that MOFED is not installed, it may slow down multi-node performance. Is this creating an issue or there might be any other problem?

Please help me.

what hardware are you running? You need pretty good specs…
Iv got a 3090 and a Ryzen 9 3900X and the LDC took me about 4 hours.

Thank you so much for your reply.
I am using Tesla V 100 graphics card. I have not installed NVIDIA drivers by the method given in the guide. Instead, I directly downloaded it from the site and then installed it. Also, I am using CUDA 11.2 version. Does this will create any problems?
Also, the MOFED driver is not installed and I am not able to install it by following the given method. Can this create any issues?

Even though if it is taking 4 hrs to solve the LDC problem, isn’t it too slow? because the same problem can be solved using CFD software in 20 seconds only.