TAO 4 Toolkit CLI install hanging up on "No module named 'tlt.entrypoint"

Attempting to Install the TAO 4 Toolkit CLI Launcher.

When I run:

bash setup/quickstart_launcher.sh --install

The install hangs up at:

ModuleNotFoundError: No module named ‘tlt.entrypoint’

Here is the full install attempt:

(nvidia) joev@joev-OMEN-by-HP-Obelisk-Desktop-875-1xxx:~/getting_started_v4.0.0$ bash setup/quickstart_launcher.sh --install
INFO: Check requirements
INFO: Checking Python installation
INFO: python3 found.
INFO: Python version: Python 3.8.10
INFO: pip3 found.
INFO: Pip version: pip 20.0.2 from /home/joev/.virtualenvs/nvidia/lib/python3.8/site-packages/pip (python 3.8)
INFO: Docker found. Checking additional requirements for docker.
INFO: Checking nvidia-docker2 installation
INFO: NGC CLI found.
INFO: NGC CLI 3.11.0
INFO: Requirements check satisfied. Installing TAO Toolkit.
By installing the TAO Toolkit CLI, you accept the terms and conditions of this license: https://developer.nvidia.com/tao-toolkit-software-license-agreement
Would you like to continue? (y/n): y
INFO: EULA accepted.
INFO: Installing TAO Toolkit CLI
INFO: jupyter installation was found.
Selected Jupyter core packages…
IPython : 8.7.0
ipykernel : 6.19.4
ipywidgets : 8.0.4
jupyter_client : 7.4.8
jupyter_core : 5.1.1
jupyter_server : 2.0.5
jupyterlab : 3.5.2
nbclient : 0.7.2
nbconvert : 7.2.7
nbformat : 5.7.1
notebook : 6.5.2
qtconsole : 5.4.0
traitlets : 5.8.0
INFO: TAO Toolkit was found
Traceback (most recent call last):
File “/home/joev/.virtualenvs/nvidia/bin/tao”, line 5, in
** from tlt.entrypoint.entrypoint import main**
ModuleNotFoundError: No module named ‘tlt.entrypoint’

Could you try below command to check if it works?
$ pip3 install nvidia-tao --upgrade

That fixed it.
Thanks

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.