TAO classification /bin/sh: 1: pip3: not found

Here is the log, explanation below

After my last reply I restored permissions for .docker and config.json to root. As a consequence when I ran ‘docker login’ permission was denied to save to config j.son. So permissions had to be changed again and the second time it was successful. Pip3 is definitely where we want it and is the Python3 one.

There is similar error log “Error starting userland proxy: listen tcp4 bind: address already in use”) " in topic Faster_RCNN sample dataset_convert command raise 'Docker instantiation failed with error: 500 Server Error: Internal Server Error'

Please change the Ports section in the ~/.tao_mounts.json from 8888 to 8889 and retry.
Refer to

Okay, I have done that. The notebook still returns
“/bin/sh: 1: pip3: not found” etc

In the screen grab I have shown the revised ~/.tao_mounts.json in the home directory and in VS where I made the revision. Please confirm that I have interpreted your instructions correctly.

Change to
“8889” : 8889

And then open notebook via browser

All done.

Can you open a new browser? If your machine has ip xx.xx.xxx.xxx, then try

my machine doesn’t like the 5th part of the address. The ‘apply’ button is green until the 4th ‘.’ is entered

(I 'xx’d the rest of the IP address, apologies)

No, I mean if your ip is xx.xx.xxx.xxx, then change below


Is this what I should do?

By the way I notice that I ran
$ which pip3
instead of

which pip3 (using hash here has the effect of enlarging font size)

$ pip3 --version
instead of

pip3 --version

docker login nvcr.io

re-running these commands as root, as per your original instructions, still returns the correct responses.

Several experiments here.

  1. In terminal, check your ip
    $ ifconfig

  2. As mentioned above, in terminal,
    $ tao classification run /bin/bash

# which pip3
# pip3 --version

  1. exit the docker
    # exit

  2. In terminal, trigger notebook in the background.
    $ jupyter notebook --ip --allow-root --port 8888 &

then open the browser via yourip:8889

then, run in notebook
! which pip3
! pip3 --version

please note the following additional screenshot from Terminal:


myip:8889 “unable to connect”
notebook is at
This is not from my ip, but here it is anyway

You can not run into the docker yet.

Please run $ docker ps to find which container allocates the “8889” port.
and then kill the container. $ docker rm -fv container-id

Then try login the docker again.

More, if issue still happens, please try to install pip3 inside the notebook.

No container appears to be allocating the “8889” port. So moving past the “kill the container”.
After reboot

This may be the issue. I am not sure how to fix this. Can you help?
(otherwise I will try to install pip3 inside the notebook)

Please upload your ~/.tao_mounts.json.

permission set to host and UID:UIG as per instructions

to do this I had to make an unhidden copy to the uploader could seeit

tao_mounts.json (797 Bytes)

trying to run (as I have no name!@2804e9964214:/workspace)
jupyter notebook --ip --allow-root --port 8889
gives a permission error.

How about running below?
$ docker run --runtime=nvidia -it --entrypoint=“” -p 8888:8888 --rm nvcr.io/nvidia/tao/tao-toolkit-tf:v3.22.05-tf1.15.5-py3 /bin/bash

then, inside the docker
$ jupyter notebook --ip --allow-root --port 8888

This means that I cannot execute the rest of your instructions, but, to be sure, you were asking me to run the jupyter notebook command using port 8888, despite changing ~/.tao_mounts.json being changed to port 8889?
I exited and re-entered docker which dealt with the “I have no name!” issue. I also used port 8888. and I am back in the notebook with pip3 not found. I will rerun your instructions before I attempt to download pip3 (python3.6) to the notebook.

Yes, this way is not related to tao-launcher.

Please try below.
$ docker run --runtime=nvidia -it --entrypoint=“” -p 8888:8888 --rm -v /var/run/docker.sock:/var/run/docker.sock nvcr.io/nvidia/tao/tao-toolkit-tf:v3.22.05-tf1.15.5-py3 /bin/bash

then, inside the docker
$ jupyter notebook --ip --allow-root --port 8888

this appears to be a step forward: however attempting to open file:

try first URL:

try second URL:

activity in the Terminal continued and after about 2 minutes it gave the following:

I then opened a new notebook in parallel to compare the difference in ip addresses: it seems to me that your instruction was correct, just the address is wrong.

$ jupyter notebook --ip --allow-root --port 8888

You should open the browser and enter yourip:8888

then if it asks you to enter passwd, then copy below one.