Tao-converter: command not found/permission denied

Please provide the following information when requesting support.

• Hardware (4Gb jetson nano, RTX 3080)
• Network Type (Detectnet_v2)

  • DeepStream 5.1

• TLT Version (dockers:
docker_registry: nvcr.io

format_version: 2.0
toolkit_version: 3.22.05
published_date: 05/25/2022

• Training spec file(If have, please share here)
• How to reproduce the issue ? (This is for errors. Please share the command line and the detailed log here.)

Hi there.

I am attempting to generate an engine with tao-converter for use on the nano. I am using the version of tao-converter for jetson devices that the link in the detectnet_v2 jupyter notebook points to (zip/folder name “clara_agx”). I am following the “Instructions for Jetson” in the “deploying to deepstream-detectnet-v2” documentation. and then the Readme.txt. inside the “clara_agx” folder in “Home” on the nano.
When I run “./tao-converter -h” I get:
“bash: ./tao-converter: permission denied”
I have tried with “chown root:root” and “chown peter:peter”
If I simply use “tao-converter -h”, I get:
“bash: tao-converter: command not found”

please advise

How about
$ chmod +x tao-converter

Thank you Morganh.

Apologies but could you confirm that the -k would be the NGC API key?

Yes. It is the key when you train the model. If the model is downloaded from ngc, you can find the key in its model card.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.