TAO ocrnet dataset_convert error

• Hardware (L4)
• Network Type (ocrnet)
• Training spec file :
config_ocr_Vinh.txt (932 Bytes)

I had error when convert my dataset. I ran :
“”"
ocrnet dataset_convert -e /OCR_Vinh/config/config_ocr_Vinh.txt
dataset_convert.input_img_dir=/OCR_Vinh/dataset/images
+dataset_convert.gt_file=/OCR_Vinh/dataset/gt_list.txt
+dataset_convert.results_dir=/OCR_Vinh/dataset_lmdb
“”"
And this is error:

Please change to -e /OCR_Vinh/config/config_ocr_Vinh.yaml

It still has the same error. This is my spec file and command:


Please check if meet the structure mentioned in the OCRNet - NVIDIA Docs.

I’ve been researching all day today and feel like this error seems to be due to my ground truth list file. I wonder if the labels part can be in sentence form and contain spaces inside? .This is my sample picture of gt file:

It can have spaces inside.
But the root cause for the error is due to your ground truth list file has an additional empty line in the end. This will result into error when run below line. tao_pytorch_backend/nvidia_tao_pytorch/cv/ocrnet/scripts/dataset_convert.py at v5.2.0_github · NVIDIA/tao_pytorch_backend · GitHub.

imagePath, label = datalist[i].strip('\n').split('\t')

Please delete the last empty line.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.