Tao Toolkit LPR error

Please provide the following information when requesting support.

• Hardware (T4)
• Network Type (LPRnet)
• TLT Version (Please run “tlt info --verbose” and share “docker_tag” here)
Configuration of the TAO Toolkit Instance
task_group: [‘model’, ‘dataset’, ‘deploy’]
format_version: 3.0
toolkit_version: 5.2.0
published_date: 12/06/2023

Looking in indexes: Simple index, https://pypi.ngc.nvidia.com
Collecting numpy<=1.19.5,>=1.17.0
Downloading numpy-1.19.5-cp37-cp37m-manylinux2010_x86_64.whl (14.8 MB)
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 14.8/14.8 MB 11.8 MB/s eta 0:00:00m eta 0:00:01[36m0:00:01
Collecting opencv-python<=4.5.5.64,>=3.4.0.12
Downloading opencv_python-4.5.5.64-cp36-abi3-manylinux_2_17_x86_64.manylinux2014_x86_64.whl (60.5 MB)
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 60.5/60.5 MB 11.8 MB/s eta 0:00:00m eta 0:00:01[36m0:00:01
Collecting pillow<=9.0.1,>=8.1.0
Downloading Pillow-9.0.1-cp37-cp37m-manylinux_2_17_x86_64.manylinux2014_x86_64.whl (4.3 MB)
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 4.3/4.3 MB 11.8 MB/s eta 0:00:00 MB/s eta 0:00:01:01
Requirement already satisfied: matplotlib<=3.5.1,>=3.1.1 in /home/glueck/miniconda3/envs/launcher/lib/python3.7/site-packages (from -r /home/glueck/getting_started_v5.1.0/notebooks/tao_launcher_starter_kit/licence_v1/…/deps/requirements-pip.txt (line 4)) (3.3.3)
Collecting scipy<=1.8.0,>=1.5.4
Downloading scipy-1.7.3-cp37-cp37m-manylinux_2_12_x86_64.manylinux2010_x86_64.whl (38.1 MB)
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 38.1/38.1 MB 11.8 MB/s eta 0:00:00m eta 0:00:01[36m0:00:01
Collecting h5py<=3.6.0,>=3.1.0
Downloading h5py-3.6.0-cp37-cp37m-manylinux_2_12_x86_64.manylinux2010_x86_64.whl (4.1 MB)
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 4.1/4.1 MB 11.8 MB/s eta 0:00:0031m11.8 MB/s eta 0:00:01
Collecting joblib<=1.1.0,>=1.0.1
Downloading joblib-1.1.0-py2.py3-none-any.whl (306 kB)
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 307.0/307.0 kB 12.6 MB/s eta 0:00:00
Collecting pycocotools<=2.0.4,>=2.0.2
Downloading pycocotools-2.0.4.tar.gz (106 kB)
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 106.6/106.6 kB 14.7 MB/s eta 0:00:00
Installing build dependencies … done
Getting requirements to build wheel … done
Preparing metadata (pyproject.toml) … done
Collecting wandb<=0.13.3,>=0.12.17
Downloading wandb-0.13.3-py2.py3-none-any.whl (1.8 MB)
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 1.8/1.8 MB 11.9 MB/s eta 0:00:0031m11.8 MB/s eta 0:00:01
Requirement already satisfied: urllib3<2.0.0,>=1.26.15 in /home/glueck/miniconda3/envs/launcher/lib/python3.7/site-packages (from -r /home/glueck/getting_started_v5.1.0/notebooks/tao_launcher_starter_kit/licence_v1/…/deps/requirements-pip.txt (line 10)) (1.26.18)
Requirement already satisfied: python-dateutil>=2.1 in /home/glueck/miniconda3/envs/launcher/lib/python3.7/site-packages (from matplotlib<=3.5.1,>=3.1.1->-r /home/glueck/getting_started_v5.1.0/notebooks/tao_launcher_starter_kit/licence_v1/…/deps/requirements-pip.txt (line 4)) (2.8.2)
Requirement already satisfied: cycler>=0.10 in /home/glueck/miniconda3/envs/launcher/lib/python3.7/site-packages (from matplotlib<=3.5.1,>=3.1.1->-r /home/glueck/getting_started_v5.1.0/notebooks/tao_launcher_starter_kit/licence_v1/…/deps/requirements-pip.txt (line 4)) (0.11.0)
Requirement already satisfied: kiwisolver>=1.0.1 in /home/glueck/miniconda3/envs/launcher/lib/python3.7/site-packages (from matplotlib<=3.5.1,>=3.1.1->-r /home/glueck/getting_started_v5.1.0/notebooks/tao_launcher_starter_kit/licence_v1/…/deps/requirements-pip.txt (line 4)) (1.4.5)
Requirement already satisfied: pyparsing!=2.0.4,!=2.1.2,!=2.1.6,>=2.0.3 in /home/glueck/miniconda3/envs/launcher/lib/python3.7/site-packages (from matplotlib<=3.5.1,>=3.1.1->-r /home/glueck/getting_started_v5.1.0/notebooks/tao_launcher_starter_kit/licence_v1/…/deps/requirements-pip.txt (line 4)) (3.1.1)
Collecting cached-property
Downloading cached_property-1.5.2-py2.py3-none-any.whl (7.6 kB)
Requirement already satisfied: psutil>=5.0.0 in /home/glueck/miniconda3/envs/launcher/lib/python3.7/site-packages (from wandb<=0.13.3,>=0.12.17->-r /home/glueck/getting_started_v5.1.0/notebooks/tao_launcher_starter_kit/licence_v1/…/deps/requirements-pip.txt (line 9)) (5.9.7)
Collecting pathtools
Downloading pathtools-0.1.2.tar.gz (11 kB)
Preparing metadata (setup.py) … done
Collecting setproctitle
Downloading setproctitle-1.3.3-cp37-cp37m-manylinux_2_5_x86_64.manylinux1_x86_64.manylinux_2_17_x86_64.manylinux2014_x86_64.whl (30 kB)
Requirement already satisfied: six>=1.13.0 in /home/glueck/miniconda3/envs/launcher/lib/python3.7/site-packages (from wandb<=0.13.3,>=0.12.17->-r /home/glueck/getting_started_v5.1.0/notebooks/tao_launcher_starter_kit/licence_v1/…/deps/requirements-pip.txt (line 9)) (1.15.0)
Requirement already satisfied: docker-pycreds>=0.4.0 in /home/glueck/miniconda3/envs/launcher/lib/python3.7/site-packages (from wandb<=0.13.3,>=0.12.17->-r /home/glueck/getting_started_v5.1.0/notebooks/tao_launcher_starter_kit/licence_v1/…/deps/requirements-pip.txt (line 9)) (0.4.0)
Collecting protobuf<4.0dev,>=3.12.0
Downloading protobuf-3.20.3-cp37-cp37m-manylinux_2_5_x86_64.manylinux1_x86_64.whl (1.0 MB)
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 1.0/1.0 MB 12.1 MB/s eta 0:00:0031m12.0 MB/s eta 0:00:01
Collecting promise<3,>=2.0
Downloading promise-2.3.tar.gz (19 kB)
Preparing metadata (setup.py) … done
Collecting PyYAML
Downloading PyYAML-6.0.1-cp37-cp37m-manylinux_2_17_x86_64.manylinux2014_x86_64.whl (670 kB)
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 670.1/670.1 kB 12.2 MB/s eta 0:00:00 MB/s eta 0:00:01
Collecting shortuuid>=0.5.0
Downloading shortuuid-1.0.11-py3-none-any.whl (10 kB)
Requirement already satisfied: requests<3,>=2.0.0 in /home/glueck/miniconda3/envs/launcher/lib/python3.7/site-packages (from wandb<=0.13.3,>=0.12.17->-r /home/glueck/getting_started_v5.1.0/notebooks/tao_launcher_starter_kit/licence_v1/…/deps/requirements-pip.txt (line 9)) (2.31.0)
Collecting GitPython>=1.0.0
Downloading GitPython-3.1.41-py3-none-any.whl (196 kB)
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 196.4/196.4 kB 13.0 MB/s eta 0:00:00
Collecting Click!=8.0.0,>=7.0
Downloading click-8.1.7-py3-none-any.whl (97 kB)
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 97.9/97.9 kB 14.6 MB/s eta 0:00:00
Collecting sentry-sdk>=1.0.0
Downloading sentry_sdk-1.40.0-py2.py3-none-any.whl (257 kB)
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 257.5/257.5 kB 12.5 MB/s eta 0:00:00
Requirement already satisfied: setuptools in /home/glueck/miniconda3/envs/launcher/lib/python3.7/site-packages (from wandb<=0.13.3,>=0.12.17->-r /home/glueck/getting_started_v5.1.0/notebooks/tao_launcher_starter_kit/licence_v1/…/deps/requirements-pip.txt (line 9)) (68.0.0)
Requirement already satisfied: importlib-metadata in /home/glueck/miniconda3/envs/launcher/lib/python3.7/site-packages (from Click!=8.0.0,>=7.0->wandb<=0.13.3,>=0.12.17->-r /home/glueck/getting_started_v5.1.0/notebooks/tao_launcher_starter_kit/licence_v1/…/deps/requirements-pip.txt (line 9)) (6.7.0)
Collecting gitdb<5,>=4.0.1
Downloading gitdb-4.0.11-py3-none-any.whl (62 kB)
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 62.7/62.7 kB 15.6 MB/s eta 0:00:00
Requirement already satisfied: typing-extensions>=3.7.4.3 in /home/glueck/miniconda3/envs/launcher/lib/python3.7/site-packages (from GitPython>=1.0.0->wandb<=0.13.3,>=0.12.17->-r /home/glueck/getting_started_v5.1.0/notebooks/tao_launcher_starter_kit/licence_v1/…/deps/requirements-pip.txt (line 9)) (4.7.1)
Requirement already satisfied: idna<4,>=2.5 in /home/glueck/miniconda3/envs/launcher/lib/python3.7/site-packages (from requests<3,>=2.0.0->wandb<=0.13.3,>=0.12.17->-r /home/glueck/getting_started_v5.1.0/notebooks/tao_launcher_starter_kit/licence_v1/…/deps/requirements-pip.txt (line 9)) (2.10)
Requirement already satisfied: certifi>=2017.4.17 in /home/glueck/miniconda3/envs/launcher/lib/python3.7/site-packages (from requests<3,>=2.0.0->wandb<=0.13.3,>=0.12.17->-r /home/glueck/getting_started_v5.1.0/notebooks/tao_launcher_starter_kit/licence_v1/…/deps/requirements-pip.txt (line 9)) (2022.12.7)
Requirement already satisfied: charset-normalizer<4,>=2 in /home/glueck/miniconda3/envs/launcher/lib/python3.7/site-packages (from requests<3,>=2.0.0->wandb<=0.13.3,>=0.12.17->-r /home/glueck/getting_started_v5.1.0/notebooks/tao_launcher_starter_kit/licence_v1/…/deps/requirements-pip.txt (line 9)) (3.3.2)
Collecting smmap<6,>=3.0.1
Downloading smmap-5.0.1-py3-none-any.whl (24 kB)
Requirement already satisfied: zipp>=0.5 in /home/glueck/miniconda3/envs/launcher/lib/python3.7/site-packages (from importlib-metadata->Click!=8.0.0,>=7.0->wandb<=0.13.3,>=0.12.17->-r /home/glueck/getting_started_v5.1.0/notebooks/tao_launcher_starter_kit/licence_v1/…/deps/requirements-pip.txt (line 9)) (3.15.0)
Building wheels for collected packages: pycocotools, promise, pathtools
Building wheel for pycocotools (pyproject.toml) … error
error: subprocess-exited-with-error

× Building wheel for pycocotools (pyproject.toml) did not run successfully.
│ exit code: 1
╰─> [23 lines of output]
running bdist_wheel
running build
running build_py
creating build
creating build/lib.linux-x86_64-cpython-37
creating build/lib.linux-x86_64-cpython-37/pycocotools
copying pycocotools/init.py → build/lib.linux-x86_64-cpython-37/pycocotools
copying pycocotools/mask.py → build/lib.linux-x86_64-cpython-37/pycocotools
copying pycocotools/coco.py → build/lib.linux-x86_64-cpython-37/pycocotools
copying pycocotools/cocoeval.py → build/lib.linux-x86_64-cpython-37/pycocotools
running build_ext
Compiling pycocotools/_mask.pyx because it changed.
[1/1] Cythonizing pycocotools/_mask.pyx
building ‘pycocotools._mask’ extension
creating build/common
creating build/temp.linux-x86_64-cpython-37
creating build/temp.linux-x86_64-cpython-37/common
creating build/temp.linux-x86_64-cpython-37/pycocotools
gcc -pthread -B /home/glueck/miniconda3/envs/launcher/compiler_compat -Wl,–sysroot=/ -Wsign-compare -DNDEBUG -g -fwrapv -O3 -Wall -Wstrict-prototypes -fPIC -I/tmp/pip-build-env-3ysibfl6/overlay/lib/python3.7/site-packages/numpy/core/include -I./common -I/home/glueck/miniconda3/envs/launcher/include/python3.7m -c …/common/maskApi.c -o build/temp.linux-x86_64-cpython-37/…/common/maskApi.o -Wno-cpp -Wno-unused-function -std=c99
gcc: error: …/common/maskApi.c: No such file or directory
/tmp/pip-build-env-3ysibfl6/overlay/lib/python3.7/site-packages/Cython/Compiler/Main.py:381: FutureWarning: Cython directive ‘language_level’ not set, using ‘3str’ for now (Py3). This has changed from earlier releases! File: /tmp/pip-install-n7vrodrx/pycocotools_85e8d469be684ab29c7337f806dd3bc1/pycocotools/_mask.pyx
tree = Parsing.p_module(s, pxd, full_module_name)
error: command ‘/usr/bin/gcc’ failed with exit code 1
[end of output]

note: This error originates from a subprocess, and is likely not a problem with pip.
ERROR: Failed building wheel for pycocotools
Building wheel for promise (setup.py) … done
Created wheel for promise: filename=promise-2.3-py3-none-any.whl size=21483 sha256=6d769f7cece19e0ea4f791ff6a16b3ea8c323e0815a34799d02a4fe600b4db3a
Stored in directory: /tmp/pip-ephem-wheel-cache-y0avgci9/wheels/9d/ad/15/e6d5c43a0f01b88ee5883bd249a18e09d72821e43b1c3e8187
Building wheel for pathtools (setup.py) … done
Created wheel for pathtools: filename=pathtools-0.1.2-py3-none-any.whl size=8793 sha256=aeb832051b70ba6c109c0d1417a00d5ce8c2ab58c5df6e5b9fb06f5e015079ff
Stored in directory: /tmp/pip-ephem-wheel-cache-y0avgci9/wheels/7b/d8/86/08d5794e37091c7a918e0bb3322b7b43af55bda3b665b81e05
Successfully built promise pathtools
Failed to build pycocotools
ERROR: Could not build wheels for pycocotools, which is required to install pyproject.toml-based projects

Installing the dependencies

import os
os.environ[“PROJECT_DIR”] = os.getcwd()
!pip3 install -r $PROJECT_DIR/…/deps/requirements-pip.txt

for this getting this why

There is no update from you for a period, assuming this is not an issue anymore. Hence we are closing this topic. If need further support, please open a new one. Thanks

May I know more detail about your steps? You can share the command line and its corresponding log. Thanks a lot.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.