TaraXL camera cannot connected

Hi folks,

Has anyone used econ TaraXL Stereo camera before? I have installed SDK and downloaded the TaraXL Studio app. However, the TaraXLStudio cannot detect the camera. I’m not quite sure whether my procedure was right because the manual wasn’t really clear to me.

I followed the video and installed the SDK and I believe this part should be correct.

However, when it comes to the TaraXL Studio software, it really confused me, because I didn’t find any instruction about it from the website. Finally, I found something from Github. https://github.com/econsystems/taraxl-tools/tree/master/taraxl-studio-qtapp What I did was to download these files and try the following command.

git clone https://github.com/econsystems/taraxl-tools.git
cd taraxl-tools/taraxl-studio-qtapp
export QT_SELECT=5

The TaraXLStudio file did appear, but it cannot detect my camera.

Another thing is that in the video (the first link), there are a ‘bin’ file and a ‘samples’ file in their installation file, but not in mine.


hello zorrolee777,

may I know which JetPack release you’re working with.
we had some bootloader update to fix usb device protocol, suggest you moving to the latest release, JetPack-4.2.1 for confirmation.

Hello JerryChang,

I believe that 4.2.1 is the version that I used.


Is the video node detected? can you please run the below command.
#ls /dev/video*

Also can you share the dmesg log of your device. After connecting the camera.


Hello vishnu.teskar,

I ran the command #ls /dev/video*, and it said no access, no such file or directory.
Here is the dmesg log and I copied it into the google doc because of its length.

Hi zorrolee,

It looks video node is not detected, also you are using older version of L4T. Please move to the latest version of L4T.

Run the below command and verify the version,
#cat /etc/nv_tegra_release
R32 (release), REVISION: 2.0, GCID: 15966166, BOARD: t186ref, EABI: aarch64, DATE: Wed Jul 17 00:26:04 UTC 2019

Hi zorrolee,

Is everything resolved?


Hello vishnu.tsekar,

Yes, the problem has been solved. Thank you so much!