TCC GPU - How to disable PCIe Not-Ready after 30sec idle.

I have a TCC GPU for compute purposes. Overall software has an “idle” feature that tells overall software to stop processing - thus, no CUDA Kernels are running and the TCC GPU is idle as well. After 30+seconds it seems that the PCIe state of the GPU becomes, “Not Ready”. When the overall software exists “idle”, the first set of data being sent to the GPU is incomplete as the GPU needs to transition from Not Ready to Ready.

Is there a way to disable this?

I suppose I could kick off an empty kernel as a part the software’s transition out of “idle” or, as a part of the idle state, have a “busy” kernel running? Both seem like a hack.


  • Windows 10
  • CUDA 10.1
  • Dual Quadro P4000s (one in TCC Mode)
  • TCC hanging off a PCIe switch (switch between CPU and GPU).

Thank you for any help.