TcpSubscriber Warning on Kaya Sim UE4

Hello,

I am trying to run the Kaya sim on the UE4. I have followed these docs:

(1) https://docs.nvidia.com/isaac/isaac_sim/setup.html
(2) https://docs.nvidia.com/isaac/archive/1.2/quickstart.html (Kaya section)

Getting an issue when I am running this command, from the 2nd doc:

./Engine/Binaries/Linux/UE4Editor IsaacSimProject Kaya_Table_P -vulkan -isaac_sim_config_json="/home/shatterhand/Projects/Navon/isaac/apps/kaya_sim/bridge_config/kaya_full.json"

The UE4 runs, also the Kaya robot and items appear in the sim. Although, I keep getting a TcpSubscriber error after I press Play.

2019-09-11 11:18:15.466 WARNING TcpSubscriber.cpp@162: Failed to connect to remote: Connection refused. Will try again in 0.500000 seconds.

then, the subsequent step of running Kaya from the SDK side aborts using this command

bazel run apps/kaya_sim:joystick
...
2019-09-11 11:31:15.628 PANIC   ./engine/alice/node.hpp@206: Could not find a component of type 'isaac::alice::Config' in node '_config_bridge'. Use `hasComponent` or `getComponents` to check for components.
====================================================================================================
|                            Isaac application terminated unexpectedly                             |
====================================================================================================

** I have verified that my Setup Paths are correct by doing a pwd in the correct directory.
pwd reveals:
/home/shatterhand/Projects/Navon/isaac/apps/kaya_sim/bridge_config

kaya_full.json

{
  "graphs": ["/home/shatterhand/Projects/Navon/isaac/apps/kaya_sim/bridge_config/kaya_full_graph.json"],
  "configs": ["/home/shatterhand/Projects/Navon/isaac/apps/kaya_sim/bridge_config/kaya_full_config.json"]
}

Hi Navon,

My guess is that you have installed Isaac SDK properly.
It seems that the problem is on the SDK side rather than the Sim side.
Have to tried other apps, like carter_sim app? does that work ok?

Thanks,
Liila

Hello Liila,

I managed to get it working, to fix the issue of the SDK and the UE4 sim not connecting, I ran the command below in the Isaac SDK root directory.

bazel build ...

Hi Navon,

Glad you got it working.

Thanks,
Liila