[?] Tegra Jetson TK1 image restore, but setting wont remeber on reboot!

[?] Tegra Jetson TK1 image restore, but setting wont remember on reboot!

I follow the instruction below to restore my image, but every reboot whatever i did in the Ubuntu wont save!


the time is now Feb 1 2000, and i use the command to change:
date 061219402014.56

or disable USB 3.0 auto suspend (this is done in: Ctrl+Alt+F1 environment)
sudo sh -c “echo -1 > /sys/module/usbcore/parameters/autosuspend”

and if i check:

cat /sys/module/usbcore/parameters/autosuspend
it says -1

but as soon as i reebot, everything back to before…

Usually nothing you change under /sys is permanent. You need to set them again on every boot. There are different configuration files for most of those. And nothing for some.

One way to run those commands on every boot, is to add them into /etc/rc.local. That’s run as root, so no need for sudo.

About setting up time&date
I did following.

sudo ntpdate ntp.ubuntu.com
echo “Asia/Tokyo” | sudo tee /etc/timezone
sudo dpkg-reconfigure --frontend noniteractive tzdata

and there is a list of timezone under

Good luck

can i edit the source file before cook in to Jetson board? if so where can i or how do i do that?

simply add it to /etc/rc.local file, and reboot (as root, eg sudo vi /etc/rc.local)

#!/bin/sh -e


This script is executed at the end of each multiuser runlevel.

Make sure that the script will “exit 0” on success or any other

value on error.

In order to enable or disable this script just change the execution


By default this script does nothing.

sh -c “echo -1 > /sys/module/usbcore/parameters/autosuspend”

exit 0