Tegra186-cam-rtcpu bc00000.rtcpu: deferring, 14800000.isp is not probed

Hi I am developing a custom driver using IMX219 in Jetson NX.
When I invoke the driver using “gst-launch-1.0 nvarguscamerasrc sensor_mode=5 ! nvvidconv ! xvimagesink”
The camera starts streaming (I probed the CSI interface to confirm that the camera is sending MIPI signal)
but I am unable to see the image data in the display.
Can anyone suggest a way to fix this problem ?

Thank you in Advance…

I am attaching the kernel dmesg file kernel_dmesg.txt (82.4 KB)

Got timeout to capture. Have a check the trace log if can get more information.

Hi @ShaneCCC ,
I tried the following commands for trace log

echo 1 > /sys/kernel/debug/tracing/tracing_on
echo 30720 > /sys/kernel/debug/tracing/buffer_size_kb
echo 1 > /sys/kernel/debug/tracing/events/tegra_rtcpu/enable
echo 1 > /sys/kernel/debug/tracing/events/freertos/enable
echo 2 > /sys/kernel/debug/camrtc/log-level
echo 1 > /sys/kernel/debug/tracing/events/camera_common/enable
echo > /sys/kernel/debug/tracing/trace
cat /sys/kernel/debug/tracing/trace
v4l2-ctl --device /dev/video0 --stream-mmap --stream-to=frame.raw --stream-count=1 --set-ctrl bypass_mode=0
cat /sys/kernel/debug/tracing/trace

I am attaching the trace log file trace (10.9 MB)
.

The log tell the start of transmit multiple bit error.
Have a check the REG NVCSI_PHY_0_CILA_INTR_0_STATUS_CILA_0 in TRM

 kworker/1:0-23160 [001] .... 17256.019282: rtcpu_nvcsi_intr: tstamp:539626670508 class:CORRECTABLE_ERR type:PHY_INTR phy:0 cil:0 st:0 vc:0 status:0x00000044

Hi @ShaneCCC ,
I am not sure how to check the error you mentioned can you suggest a way to find the problem and solve it ?

I tried to add a ISP_Overide file and I got the camera data somewhat odd… Please have a look at the image I got

The overide file I used wascamera_overrides.isp (105.1 KB)

Please let me know how to solve it.

What’s the sensor? imx219?

Hi @ShaneCCC ,
I am using a sensor from omnivision but I modified the IMX219 Driver and the respective device tree.
I have edited the below two files in the jakku folder please have a look and let me know if I have made any mistakes in the device tree
tegra194-camera-rbpcv2-imx219.dtsi (24.3 KB)
tegra194-camera-jakku-rbpcv2-imx219.dtsi (1.9 KB)

OK, so it’s doesn’t matter with imx219.
The start of transmit error maybe relative the MIPI timing or HW problem. You may need consult with sensor vendor to get help.

Hi @ShaneCCC ,
I am not sure if I need to make additional changes. I built a custom camera driver using ov5693 as reference in AGX and it is working. Now I am trying to build the driver for the same sensor using IMX219 as reference in NX.

Am I missing something please let me know what are the required changes I have to make ?

You can using the driver for AGX and just modify the DTS for NX to verify.

Hi @ShaneCCC ,
I tried using the agx driver and modified the device tree for nx and still having the same issue.

I will attach the trace log file here.trace (5.9 KB)

The trace log tell didn’t receive any validate data from MIPI bus.

Hi @ShaneCCC ,
But How do I get some odd data when i add ISP_override file which i mentioned in this post
Please let me how how to fix this.

Sorry, I have no idea for it. But you should verify the driver and HW by v4l2-ctl first.