tegra3 seco board gstreamer

Hi,

I have to use gstreamer for my project over SECO development kit. I have gstreamer and gst-plugin-base installed on the root file system. but the existing root file system do not have the binaries like gst-launch, gst-inspect and other binaries while building the gstreamer package. So i made the package at my host system and copied the binaries to the /usr/bin folder. after that i tried the following command:

#gst-launch-0.10 playbin uri=file:///home/file_name.mp4 , but the output is:

error: ERROR: pipeline could not be constructed: no element “playbin”.

i did some google on this and found that libgstplaybin.so is required for this. i copied the libgstplaybin.so ( build with correct version number of gst-plugin-base and toolchain). and after that if i run the above command again:

#gst-launch-0.10 playbin uri=file:///home/file_name.mp4

this time output shows some GLIB-GObject-critical message of uint64 range assetion failed and after that it gets crashed.

in my current development system, i also dont have the gui on my board, i also want to have the usual ubuntu gui look to play the video or test the video. please suggest me what to do in this regard …

thanks

Punit