Tegracam imx477 not working

All I need is to set status to okay, like this?

#include "tegra210-camera-rbpcv3-dual-imx477.dtsi"

#define CAM1_PWDN		TEGRA_GPIO(S, 7)
#define CAM2_PWDN		TEGRA_GPIO(T, 0)
#define CAM_I2C_MUX		TEGRA_GPIO(I, 0) // NFC_EN GPIO

/ {
	cam_i2cmux {
		compatible = "i2c-mux-gpio";
		#address-cells = <1>;
		#size-cells = <0>;
		mux-gpios = <&gpio CAM_I2C_MUX GPIO_ACTIVE_HIGH>;
		i2c-parent = <&i2c7>;
		i2c@0 {
			reg = <0>;
			#address-cells = <1>;
			#size-cells = <0>;
			rbpcv3_imx477_a@1a {
				status = "okay";
				reset-gpios = <&gpio CAM1_PWDN GPIO_ACTIVE_HIGH>;
			};
		};
		i2c@1 {
			reg = <1>;
			#address-cells = <1>;
			#size-cells = <0>;
			rbpcv3_imx477_e@1a {
				status = "okay";
				reset-gpios = <&gpio CAM2_PWDN GPIO_ACTIVE_HIGH>;
			};
		};
	};

	gpio@6000d000 {
		camera-control-output-low {
			gpio-hog;
			output-low;
			gpios = < CAM1_PWDN 0  CAM2_PWDN 0>;
			label = "cam1-pwdn", "cam2-pwdn";
		};
	};
};

with last setting I have followed Kernel output:

[    1.316561] imx219 7-0010: imx219_board_setup: error during i2c read probe (-121)
[    1.316654] imx219 7-0010: board setup failed
[    1.340525] imx219 8-0010: imx219_board_setup: error during i2c read probe (-121)
[    1.340585] imx219 8-0010: board setup failed

hello waldemar.friesen,

okay, the default camera configuration is IMX219 on Jetson Nano. that’s why you see kernel logs to parse IMX219 camera sensor.
there’s Jetson-IO to have CSI config to select cameras, and it only works on developer kits.

since you’re using camera module from Arducam, you may have device tree modification to apply the camera configuration.

OK. So I install drivers of imx477 camera. Only then will the kernel output:

[    1.581985] imx477 7-001a: imx477_board_setup: error during i2c read probe (-121)
[    1.589623] imx477 7-001a: board setup failed
[    1.894865] imx477 8-001a: imx477_board_setup: error during i2c read probe (-121)
[    1.902459] imx477 8-001a: board setup failed

maybe I have to change something in files gpio and pinmux?

hello waldemar.friesen,

since it’s your customize board, please check you’ve given correct regulator settings to enable the camera board.

Do you mean with that the power supply 3.3V for camera board? I have measured 3.3V at camera pins.

hello waldemar.friesen,

normally, there should be 3.3v, 1.8v, and 1.2v as power-supply, and it also takes GPIOs for reset and pwdn to enable camera board.
in addition, please check you’ve correct i2c-bus and i2c-address configuration in the device tree.

ok voltage is matching. gpio is set properly. which settings are needed for i2c ?

hello waldemar.friesen,

i2c-bus and i2c-address configuration in the device tree.
you’ve apply camera vendor’s source package, right? do they have release binary to have quick verification on developer kit?

I have followed these Instructions and my Hardware is like official supported developer kit. But I guess these instructions don’t fit to the arducam hardware B0251, it is only for current available cameras and not B0251.

I have checked pinmux spreadsheet on download page. There is only latest for L4T 32.2.x., which doesn’t support imx477 - I guess. is it possible to get the spreadsheet for 32.7.2 or 32.7.1 ?

with which ubuntu version can be used JetPack 4.3? I have problems with login under Kubuntu18.04LTS. Or can JetPack 4.3 be flashed in current docker version from sdkmanger ?

hello waldemar.friesen,

since you’re using your customize board, and this IMX477 isn’t Nano’s default support camera module.
had you verify the camera module on Jetson developer kits?

I found the reason why it doesn’t work. It’s not on board. To do everything right, I need JetPack 4.3, because only then can the dev tree be set up properly and this JetPack version cannot be used due to login problems. Otherwise I hope on Arducam that the deb binary for B0251 will be created to match the current JetPack. Arducam is already on to it.