Telsa GPU and Datacentres

Looking for some help in knowing exactly what I should be asking a Datacentre based on my requirements.

where can i find out what cuda versions are compatible with telsa cards and operating systems? it may sound an obvious question but checking the driver download page for example produces anything for download and we had already wasted alot of time trying to run a older card M2090 on windows server 2012 r2 using cuda 9.1 didnt work and found that out in a forum where they said support for cuda stopped at ver 8 for that card.

look forward to any help trying to get the real information about telsa card/cuda version/OS version compatibility