TensorFlow for Jetson TX2!

Hi all!

Are you sure the right command is:

pip3 install --extra-index-url=https://developer.download.nvidia.com/compute/redist/jp33 tensorflow-gpu

for my Mac i’s working without “=”

pip3 install --extra-index-url https://developer.download.nvidia.com/compute/redist/jp33 tensorflow-gpu

That’s why error are raised ?

Thanks for updating the status for MAC.
The command we shared is for Ubuntu.

Thanks.

could you please offer some other packages’ .whl file download path like opencv for python3, so that makes us install opencv in jetson tx2 easy like tf-gpu instead of compiling from the source

for example:
pip3 install --extra-index-url https://developer.download.nvidia.com/compute/redist/jp33 opencv-python

Hi,

OpenCV python interface can be installed with this command directly.

sudo apt-get install python-opencv

Thanks.

I have installed Jetpack3.3 and Tensorflow 1.9.0 use:
pip3 install --extra-index-url=https://developer.download.nvidia.com/compute/redist/jp33 tensorflow-gpu

run graph on CPU make right result but run on GPU make wrong result and out different results with same input
example code: https://1drv.ms/u/s!AhFk3ICqlZI2irJdcWsWHKtBHhrt5w
run on CPU: CUDA_VISIBLE_DEVICES=’’ python3 test.py
run on GPU: python3 test.py

what error?

Hi, anhtu812

Since your issue is not related to installation, could you open a new topic for your issue?
Thanks.

Will the C++ api be supported in the future release?

Hello,

I ended up loading tensorflow on my TX2 via this new supported installation. Worked fast and a lot less work then previous means.

pip3 install --extra-index-url=https://developer.download.nvidia.com/compute/redist/jp33 tensorflow-gpu

I am having an issue with the install. I dont get any errors or warnings, but when I go to use ‘protoc’ I get a binary file error.

nvidia@tegra-ubuntu:~$ protoc --version
-bash: /home/nvidia/bin/protoc: cannot execute binary file: Exec format error

Any reason as to why the binary for the protobuf installation would be wrong?

When i do

which protoc

I get the result

/home/nvidia/bin/protoc

so I ended up reflashing the TX2 fresh. This time I installed protobuf from source first before I did anything else. I then went through the process of installing opencv and then finally tensorflow. I now have a working potoc command.

Hello.

Is it possible to update tensorflow-gpu to 1.12?

>>> import tensorflow as tf
>>> print(tf.__version__)
1.9.0

I have to disable ReduceLROnPlateau for model training with this version (see: https://www.tensorflow.org/api_docs/python/tf/keras/callbacks/ReduceLROnPlateau).

Or is there any easy way or a script to compile from latest source version?

Hello.

I installed tensorflow-gpu on my JetsonTX2 using following command.

pip3 install --extra-index-url=https://developer.download.nvidia.com/compute/redist/jp33 tensorflow-gpu

Then, I executed tensorflow but I got following errors.

nvidia@tegra-ubuntu:~/Downloads$ python3
Python 3.5.2 (default, Nov 12 2018, 13:43:14) 
[GCC 5.4.0 20160609] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>> import tensorflow
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/home/nvidia/.local/lib/python3.5/site-packages/tensorflow/__init__.py", line 22, in <module>
    from tensorflow.python import pywrap_tensorflow  # pylint: disable=unused-import
  File "/home/nvidia/.local/lib/python3.5/site-packages/tensorflow/python/__init__.py", line 47, in <module>
    import numpy as np
  File "/home/nvidia/.local/lib/python3.5/site-packages/numpy/__init__.py", line 142, in <module>
    from . import core
  File "/home/nvidia/.local/lib/python3.5/site-packages/numpy/core/__init__.py", line 59, in <module>
    from . import numeric
  File "/home/nvidia/.local/lib/python3.5/site-packages/numpy/core/numeric.py", line 3093, in <module>
    from . import fromnumeric
  File "/home/nvidia/.local/lib/python3.5/site-packages/numpy/core/fromnumeric.py", line 17, in <module>
    from . import _methods
  File "/home/nvidia/.local/lib/python3.5/site-packages/numpy/core/_methods.py", line 158, in <module>
    _NDARRAY_ARRAY_FUNCTION = mu.ndarray.__array_function__

What is this error?

Best regards.

Hi,

Could you try this command:

sudo apt-get install python3-numpy

Thanks.

Hi,

Thank you for your help!
I solved my problem.

I have started to work with a JETSON TX2 board. It already had an OS installed in it when shipped and I began to install further libraries on top of it without flashing. I have thoroughly followed the instructions specified in the Jetpack 3.3 Installation Guide. In the component manager section I have set the “Flash OS Image to Target” to “no action” mode.
After that, in the board I have installed Tensorflow-gpu from the site as mentioned in the respective guide. But while trying to run python codes using tensorflow I got the error that “CUDA driver version is insufficient for CUDA runtime version”. The CUDA driver version in the JETSON TX2 board is 8.0 while it is supposed to be 9.0. A

  1. Please mention any possibility of upgrading the CUDA driver version without reflashing the system.
  2. I have also changed some wheel versions during the scikit-learn installation, can that affect the driver version issue?

Is this version of tensorflow for Jetpack 3.2 or 3.3 ?? Cause I’m able to install it but when I want to use it I have a CuDNN runtime library error.

Im using Jetpack 3.2.1 with CuDNN 7.0.5 and it says “source has been compiled using CuDNN 7.1.5”
so I’m kind of blocked here…

Hi,

I am new to jetson TX2. For my TX2, here is the system information:

  1. Jetpack3.3
  2. CUDA-9.0
  3. PYTHON3.5 - installed

Currently I used following command to install the tensorFlow:

pip3 install --extra-index-url=https://developer.download.nvidia.com/compute/redist/jp33 tensorflow-gpu

But after “successful” installation, python3.5 even can’t do: import tensorflow (can’t find the module).

Then, I have tried several other ways, such as build the wheel file and do the bazel build. But none of them works for me.

Can someone help me how I can build the tensorFlow on my jetson TX2 in correct way?

Thanks so much
Jimmy

Hi, vincent.dufour

This wheel file is built with JetPack 3.3.
Please use it to solve the dependency issue.

Thanks

Hi, jqin2014

Could you give this command a try?

pip3 install --extra-index-url=https://developer.download.nvidia.com/compute/redist/jp33 tensorflow-gpu --user

Thanks.

Hi Aastalll,

is there any existing tensorflow-gpu version for Jetpack3.2.1 available ?

The only wheel I could find is a tensorflow-cpu version but none for gpu.

Thank you in advance

Hi, vincent.dufour

You can check the TensorFlow package built from the community.
For example:
https://github.com/peterlee0127/tensorflow-nvJetson

Thanks.